Krescue for EDGE (Rockchip rk3399)


start Krescue from SD / better to do this via press KEY_F x 3 times

Krescue Updates for Edge

  • FROM: Wed May 12 03:50:47 2021
  • TIME: 1620791447
  • VER : 210512_153
  • fast emmc erase - FIXED
  • device info - FIXED
  • fethernet problem - FIXED
  • some other small bug - FIXED


you don’t forget us.
thank you


Krescue have same support level for both series (Edge Vim)

1 Like

@hyphop Updated to the latest Krescue 210608_422, the MMC is still not accessible without the hs400->hs200 modification.

If missed my MMC details: /dev/mmcblk2 => MMC BJTD4R 29.1 G 31268536320

OK ! problems was detected !!!
Krescue already update and this issue was fixed too

plz check and confirm it ! how its works on your side !!!

I just downloaded this file and let my Edge-V boot into Mask Rom mode (3x Function button in 2 sec), I can see that Rescue starts booting, but I don’t get the menu.
I see Edge-V gets IP and is searching for boot.src.uimg from TFTP Server (from my router)??

Fev lines before that after part where “Booting kernel” are listed I see:

Ramdisk image is corrupt or invalid

SCRIPT FAILED: continuing...
Card did not respond to voltage select!: -110
Scanind disk mmc@fe31000.blk...
Disk mmc@fe310000.blk not ready.
Scanning disk mmc@fe320000.blk...
Scanind disk sdhci@fe330000.blk...
** Unrecognized filesystem type **
Found 3 disks
No EFI system partition
BootOrder not defined
EFI boot manager: Cannot load any image
switch to partitions #0, OK
mmc0(part 0) is current device
** No partition table - mmc 0 **
Couldn'f find partition mmc 0:1
rockchip_pcie pcie@fe8000000: failed to find ep-gpios property
Speed: 10000m full duplex
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
DHCP client bount to address 1x.x.x.x (3803 ms)
Using ethernet@fe300000 device
TFTP from server 1x.x.x.x; our IP address is 1x.x.x.x
Filename 'boot.scr.uimg'.
Load address: 0x1000000
Loading: T T T T T T T T
Retry count exceeded; starting again
Retrieving file: pxelinux.cfg/00000000-0000-0000-0000-000000000000
Speed: 1000, full duplex

And so going on and nothing happens. What I am doing wrong?

  1. tripple FUNCTION no need
  2. latest image

Oh I did not notice that there is new product which replaces Krescue (was this announced somewhere?).

Thanks for the Link but seems is down currently (01.08.2022 08:34 CET Time Zone)

Edit #1:
As of 09:45 CET Time Zone i am able to download images again. Let’s test this oowow!

Edit #2 tripple FUNCTION is STILL needed on Edge-V (maybe there is something on eMMC (I think Android). Without it I just see black screen (waited 5 Minutes), after pressing tripple Function i saw oowow beta splash, but still this one also does finish booting. See still that TFTP thing and no reaction on keyboard enter, esc etc…

Probably is best to find USB to TTL and check what is going on and copy whole log. And open new Topic.

still not announced for old board - testing …

I see well I would be glad to test. Because even Krescue does not work on my side.

I have an question regarding USB-to-TTL. With Putty I am having problems like written on SecureCRT Bug.
And under Linux (Manjaro KDE spin) I am unable to run kermit provided by you, and “ckermit” seems does not start correctly. I did use same USB-to-TTL in past with same Putty Version just it was VIM2

Speed: 115200 and what is written on that page the 1500000.
See log below for kermit Problem

usb 1-2: new full-speed USB device number 4 using xhci_hcd
usb 1-2: New USB device found, idVendor=067b, idProduct=2303, bcdDevice= 3.00
usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: USB-Serial Controller
usb 1-2: Manufacturer: Prolific Technology Inc.
usbcore: registered new interface driver pl2303
usbserial: USB Serial support registered for pl2303
pl2303 1-2:1.0: pl2303 converter detected
usb 1-2: pl2303 converter now attached to ttyUSB0

GND 	17
Linux_RX 	18
Linux_TX 	19

$ vim ~/.kermrc
$ kermit
kermit: error while loading shared libraries: cannot open shared object file: No such file or directory
$ ckermit
/var/lock: Permission denied
?No keywords match - 1500000
File: /home/vrabac/.kermrc, Line: 2
Sorry, you must SET LINE or SET HOST first
C-Kermit 9.0.302 OPEN SOURCE:, 20 Aug 2011, for Linux (64-bit)
 Copyright (C) 1985, 2011,
  Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/vrabac/) C-Kermit>

Edit #1
@hyphop Is the Edge-V supported baudrate only the 1500000?
Seems both my USB-to-TTL cable does not support that baudrate (PL-2303 XA / XHA chip and CP2102 ).

linux users can use easiest way

open serial console UART for rk3399 Edge1

screen /dev/ttyUSB0 1500000

But not if the Chip on USB-to-TTL does not support that. Is ‘1500000’ only baud rate for Edge-V? As this was not the case with VIM1 (Khadas Vim An Open Source TV Box AP6255 802.11b / n / g / ac WiFi Size:2GB+16GB) as I use these cable with it.

CP2102 (Silicon Labs) Chip Baud rate: 300bps - 1Mbps
PL2303 (Prolific) Chip Baud rate: 75 to 1.2M baud

Which USB-to-TTL you have used with Edge-V or your co-workers?

works fine with my

lsusb |grep Serial
Bus 003 Device 045: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

Supports baud rates from 50 bps up to 2 Mbps.
Supports CH341 driver.
Based on 340G chip.

PS: i think based on other FT232?? same must works fine

Well my do not work. And this is now problem. Can you provide me with a link where did you get yours?

In future I hope you will start offering such product with Khadas board as it is Firefly (CP2104 USB-to-UART serial port converter) doing.

Now back to my Problem, do you have any Idea why Krescue or OOWOW does not finish booting on Khadas Edge-V Pro (4GB LPDDR4 / 32GB EMMC 5.1; AP6398S Wi-Fi) version?

  1. tell me which emmc content OS
  2. oowow uboot support hdmi output and usb keyboard input - same can get some info
  3. i will check tomorrow
  • An ancient Android version 7.1.2 with April 5, 2017 patch level, Build number: Edge-V-Nougat_20190527. I think this is what came with Khadas Edge-V , never bother to update it. I was running for some tests LibreElec from mSD card.
  • that is true, after 20min or more, I can see it timeout and i see there is help with some information’s. Let me know what should I provide for you.
  • that would be great. I will also get an USB-to-TTL with CH340G (WCH) chip in two days.

@hyphop Do I need to change anything on oowow or krescue image to get output on USB-to-TTL? I got now the “ID 1a86:7523 QinHeng Electronics CH340 serial converter” but I don’t get anything under Windows 10 with putty or Manjaro KDE minicom.

Also if I let boot Android from eMMC I also don’t seen anything on serial console.

I got this on Monitor when starting oowow (tripple function). Please Note I typed this from Monitor!

U-Boot 2021.07 (Nov 12 2021 - 11:31:22 +0800)

SoC: Rockchip rk3399
Reset cause: POR
Model: Khadas Edge-V
DRAM: 3.9GiB
MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0
Loading Environment from MMC... *** Warning - bad CRC, using default environment

In: serial
Out: vidconsole
Err: vidconsole
Model: Khadas Edge-V
fusb302_init: Device ID: 0x91
Net: eth0: ethernet@fe300000
6079 bytes read in 6 ms (989.3 KiB/s)
starting USB...
Bus usb@fe380000: USB ECHI 1.00
Bus usb@fe3a0000: USB OHCI 1.0
Bus usb@fe3c0000: USB EHCI 1.00
Bus usb@fe3e0000: USB OHCI 1.0
Bus dwc3: Register 2000140 NbrPorts 2
Startin the controller
scanning bus usb@fe380000 for devices... 1 USB Device(s) found
scanning bus usb@fe3a0000 for devices... 1 USB Device(s) found
scanning bus usb@fe3c0000 for devices... 1 USB Device(s) found
scanning bus usb@fe3e0000 for devices... 1 USB Device(s) found
scanning bus dwc3 for devices... 1 USB Device(s) found
	scanning usb for storage devices... 0 Storage Device(s) found
Setting bus to 8
Hit SPACE in 2 seconds to stop autoboot

kedge# version
U-Boot 2021.07 (Nov 12 2021 - 11:31:22 +0800)

aarch64-none-linux-gnu-gcc (GNU Toolchaing for the A-profile Arch...
kedge# mmcinfo
Device: sdhci@fe330000
Manufacturer ID: 15
OEM: 100
Name: BJTD4
Bus Speed: 52000000
Mode: MMC High SPeed (52Mhz)
Rd BLock Len: 512
MMC version: 5.1
High Capacity: yes
Capacity: 29.1 GiB
Bus Width: 8-bit
Erase Group Size: 512 KiB
HC WP Group Size: 8 MiB
User Capacity: 29.1 GIB WRREL
Boot Capacity: 4 MiB ENH
RPMB Capacity: 4 MiB ENH
Boot area 0 is not write protected
BOot area 1 is not write protected

yes right: serial and video console works with usb keyboards same time in multiplex

Do I need to change anything on oowow or krescue image to get output on USB-to-TTL?

no need to change its common for rockchip baudrate 1500000 for example screen /dev/ttyUSB0 1500000

get me same output log but without press any key!

Finally get it working. I needed to swap TX and RX on that CH340G (WCH) USB-to-TTL or the GPIO Pinout on Khadas wiki is wrong, or what probably best answer is, is how USB-to-TTL works: USB TX → Board RX, USB RX → Board TX, GND → GND?

Here the Boot output from Android on eMMC . Password: khadas
Here the Boot output from oowow on mSD card without pressing tripple Function. As you can see it does not boot from alone. Password: khadas
Here the Boot output from oowow on mSD card with pressing tripple function button to boot. Password khadas

Let me know if you need anything else?