Kodi in Mainline Ubuntu


I installed Mainline Ubuntu 20.04 ( VIM3_Ubuntu-gnome-focal_Linux-5.16-rc2_arm64_SD-USB_V1.0.9-211217.img) in sdcard and boot on Khadas VIM3-Pro board.

I installed kodi. but kodi is not opening.
(1) does kodi supported in mainline <VIM3_Ubuntu-gnome-focal_Linux-5.16-rc2_arm64_SD-
USB_V1.0.9-211217> ?

(2) are there any way to run kodi in mainline linux ?

@tushar Mainline kernel not support kodi. If you need to use kodi on VIM3, you can use 4.9 kernel firmware.

Thanks @Frank

I have also another khadas VIM3L board. Mainline kernel will also not support kodi for VIM3L board ?

@tushar All of Mainline Ubuntu firmware not support Kodi.

@Frank what exactly is the problem? … because current Kodi (19) should run on Ubuntu. I’d expect that you’d need to use GBM/Wayland to run on an ARM board, but it should work.

@chewitt The 4.9 kernel Kodi is compiled by ourselves from the source code, and there are some dependency problems that need to be solved. We haven’t tested it on mainline yet. It is a good choice for the mainline kernel to use LibreELEC’s firmware directly. BTW, I will find time to test with Mainline

I am using kodi on manjaro arm plasma using wayland session on my vim3 with latest mainline kernel. It can also be configured as primary desktop session so it basically starts directly kodi on boot.

Kodi 19 (Matrix) dropped support for amcodec, so it does not support install on the Linux 4.9 vendor kernel unless you hack support back in (as CE does) but the first post in this thread states the user is running Linux 5.16, which should support Kodi running under GBM/Wayland. The VDEC is not in the best shape, but VIM3 is powerful and all 1080p media should software decode well. If you want to venture into hardware decoding you’d need to raid my kernel patchset for VDEC driver patches, and build a custom Kodi package that uses ‘external’ ffmpeg (not built-in) and then build FFMpeg using the sources LE uses for RPi in LE10 as these contain major V4L2 improvements that also solve a bunch of issues for Amlogic devices as well - although the VDEC driver is still ‘work in progress’ and 4K/10-bit media causes problems (H264 and 8-bit HEVC and VP9 should be usable though). Again, on a desktop system the easy route is normally software decoding.


Thanks All

Ya , Those are Useful information for us


Today Tried kodi instilling in Ubuntu 20.04 ( VIM3_Ubuntu-gnome-focal_Linux-5.16-rc2_arm64_SD-USB_V1.0.9-211217.img) via snapd < sudo snap install mir-kiosk-kodi >. it was installed and run successful using Wayland. when i play 1080p video from local storage ,it was playing fine. by observing cpu usage i was surprised , it was use less cpu.

any idea , is this use hardware video codec or software video codec ?

same thing i tried on khadas VIM3L board with mainline linux but cpu use goes to very high up to 80%