Khadas VIM4 scrcpy displays green screen

Hi Team,

  1. Using OOWOW I have installed 64bit Android 11 image got available in June.
  2. Compiled 64-bit SDK Download The Android Source Code | Khadas Documentation
  3. When ran built script, it was halting in between, so followed emmc burn way
    Install OS into eMMC | Khadas Documentation
  4. fastboot, adb reboot, adb root, adb shell I could able to do.
  5. After bootup, when did scrcpy, displaying green screen continuously.
    Can you please guide me, am I missing anything.

While it is running remove HDMI monitor then plug it back in. It does that on Ubuntu server too. It will only do it one time, so far it has not come back.

Thanks its showing UI as expected, but I am unable to operate it with scrcpy from terminal launch as its still continuous green.
Have connected mouse to VIM4 & through it am operating GUI.

Please take a picture of the screen and post it.

Attached adb logcat log at the time of board display shows green screen through scrcpy.
I tried even with lowering the resolution with -m but still it always shows green, even post reboot.

Let me know how can I attach adb logcat log text file over here.

Mine had all the text in green, I assumed that is what you had going on. Not sure what is wrong with yours I have not had that type of screen appear.

Do make sure your USB C cable is rated for 5 amps and your power supply is low noise and stiff.

I was connecting USB Type A to VIM4, Type C to PC (for adb log debug & power, above figure).
When I connected 24W power adaptor’s Type C to Type C to board, unable to get log through ADB, as nothing is connected to PC (below figure where adaptor is temporarily removed from power source for photo).

Let me know if I am missing anything in connection setup or how can I power up & adb access also simultaneously, on board with which connector, how to setup required connections for it.

Best way is to use TTL to USB convertor connected to the GPIO header pins. Your Khadas power supply is fine just connect it directly to the board.

Thanks, as per suggestion 24W power adapter to USB Type C cable to VIM4.

  • TTL to USB Rpi cable connected as: black lead to GND Pin17 of VIM’s GPIO, green lead to RXD Pin18 of VIM’s GPIO(Linux_Rx), white lead to TXD Pin19 of VIM’s GPIO(Linux_Tx)
  • Configured serial debugging tool as per:
    Serial Debugging Tool | Khadas Documentation
    But though LED is solid White, even after ‘R’ pressed after reboots, it shows nothing for khadas login over minicom (detected it as ttyUSB0), so currently trying to debug it. Meanwhile if you will have any suggestions kindly share.


Make sure the baudrate is correct.
Check USB adapter make sure the dip switches (if it has them) are set properly
USB and GPIO pins must be connected prior to powering up VIM board.

You should see something on minicom even if the text is garbled up, something should be shown.
I would test the USB converter setup on something that is known working from past testing.

When you get minicom up you can log the entire minicom session using this:

$ pwd
$ minicom vim4 | tee code/BootLogs/vim4.test1

vim4 > custom config you created using the VIM 4 parameters for minicom


Is a path for the filename that you want to use.

To view the log you can use either of these:

$ more code/BootLogs/vim4.test1
$ cat code/BootLogs/vim4.test1

With more press the spacebar to increment the page or hit enter for one line at a time.
Press q to exit more

Yes I have followed the same ‘Setup Serial Communication’ link steps mentioned with baud rate 921600 configured in minicom, along with other configuration settings mentioned.
But with hard reboot also I am not seeing any response or even khadas login etc. over ttyUSB0 (confirmed it by connecting/dis-connecting). ttl-USB cable connected to GPIO is also working one.
I was going through other alternatives but couldn’t found any other ways.

Does the LED turn on and what is the initial color? solid or flashing and does it change from solid to flash?

What type of TTL adapter are you using, if possible post an image of it.

Might try to reburn oowow on the SD or try a different SD card, some cards are flaky and some work perfectly. When reburning oowow image make sure you do a full erase of the SD card before reburning the image.


Thanks for some more suggestions, its a solid white LED, it didn’t changed from solid to flash.
TTL to USB is of of Prolific, from log I checked.
I was hoping with mentioned settings Serial Debug will work.

As I didn’t had SDcard, so I followed VIM4 64-bit SDK built script, it was halting after ‘fastboot $sern flash dts dt.img’, so instead of flash images script debugging, I followed emmc burn way to flash update.img
I could able to boot up board & over GUI also I could able to navigate using mouse.
Issue was with scrcpy, through Type A to Type C cable it was showing green screen, so remotely we couldn’t work over board which is in lab. We need to be in front of TV connected through HDMI to operate over UI, using VIM4 connected mouse.

I will try to check with SDcard, if that’s the only option left to try for above issue.

Have you tried ssh into it, all I use is ssh and the linux port to work remotely. Pretty sure android has ssh, we only use Linux.

Use oowow on the SD card and you should be able to get it working fine, just let the wizard install the OS. I did check the android image on dl.khadas and it does work fine.

That would be an issue with the OS installation, it should be flashing if the kernel is running.

why u need oowow sd image? , in normal situation your can always start oowow without everything , just press FUNCTION + Reset =>, after u can try restore / diag or reinstall your broken system

1 Like

I had to erase all of the memory in our board.

Just looked at the link, thank you that is good information

erase SPI flash ? why need erase SPI flash , another question how ?

On other 2 boards with OOWOW followed and it didn’t gave scrcpy Green display issue, so will work with HDMI display for time being with this board and in between releases whenever will get time, will follow OOWOW again, hopefully it will work as you suggested with fresh flash.

Able to see serial port connect as well on one of the board, so if in case anything needed can try with that option as well. Thanks experts for your help and suggestions.