Khadas VIM2 is not working


My Khadas VIM2 Max is not working any more after 18 months of usage.

When I power VIM2, LED is lightning, but Android system is not booting.
I tried to connect VIM2 to Windows10 PC and enter Upgrade mode, but USB_Burning_Tool_v2.1.7.0 can’t find the device. Previously this tool worked for me and device was detected.
Then I tried Mregister Mode, no progress as well.

My Khadas VIM2 is using VIM2_Nougat_V180619 firmware.
Power adapter 5V 2A.
I tried different adapters and USB C cables, nothing helped me.
Firmware was not updated, no new apps were installed recently.
Product has standard configuration - no heatsink, fan, VTV, tone board installed.

Please help me to recover my VIM2.

Thank you.


Hi @SuperDario , Does the displays screen have any output? Can you use the serial port tool? If you can, you can see the situation of the board from the serical port?Thanks.


Display doesn’t show anything.

Can you give me some hints how to use serial port tool? I never used it before.

HI @SuperDario , There is hot to use serial port tool.If you use it for the first time, you may encounternary problems.You can com baock here and ask.Thanks.


It means I need USB & pin adapter and Linux OS?

Hi @SuperDario , Android firmware can also use serial port tools