Khadas vim1 ubuntu16.04 mate安装vnc


#1

khadas vim1 ubuntu16.04 mate安装vncserver后,使用vnc连接显示灰屏,配置步骤为
1、sudo apt-get -y install vnc4server
2 、vncserver 启动vncserver设置vnc密码
3、vim ~/.vnc/xstartup
4、在最后一行添加 mate-session &


5、vncserver -kill :1 关闭vncserve重新启动ncserver
如上图配置完成后,使用win7pc端vnc连接显示灰屏 麻烦khadas工程师帮忙看下谢谢!

参考博客: https://www.htcp.net/880.html
https://blog.csdn.net/Mr_dhy/article/details/82822439


#2

Hi chengyiwang,

请参考这篇博客:


#3

Continuing the discussion from Khadas vim1 ubuntu16.04 mate安装vnc:

hi,khadas工程师,有几个问题麻烦帮忙看下谢谢诶,1在khadas登陆界面时连不上网啊,每次重启后还需要接键盘登陆khadas账户后才能使用ssh远程,2.vnc配置过自启动不生效啊,每次还需手动开启vncserver服务才能远程 3. Vnc配置文件添加过mate-session 每次重启后连接还是灰屏必须重启vncserver才能显示mate桌面,4.每次关机重启需要将近15分钟的时间
配置图片
QQ%E6%88%AA%E5%9B%BE20181107080223
image
image
image
在登录界面时网络不通无法ssh与vnc远程


image


#4

Hello chengyiwang,

你用的那个版本的固件?

你用的有限还是Wi-Fi?

我用VIM1_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31测试,不登录也会自动联网的。你可以登录你的路由器管理页面查看。如果你使用的是有线网,你之所以无法ssh登录可能是IP地址变了,你进路由器查看一下。VIM1目前的固件是随机的MAC地址,所以每次重启IP可能会变,你可以先进系统设为为固定MAC地址,这样IP就不会变了。

按如下方式设置固定MAC地址,编辑/etc/rc.local添加如下:

ifconfig eth0 down
ifconfig eth0 hw ether 1a:f4:a0:7b:31:6f
ifconfig eth0 up

修改后为:

root@Khadas:~# cat /etc/rc.local 
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#/boot/hdmi.sh &

# Add write right for fw_setenv
chmod 666 /dev/env

# Setup LED: breathing if bootup completed
echo breathe > /sys/class/leds/red/trigger

ifconfig eth0 down
ifconfig eth0 hw ether 1a:f4:a0:7b:31:6f
ifconfig eth0 up

exit 0

或者你使用Wi-Fi,IP地址也不会变。

我按下面博客配置,没有看到你说的现象