Khadas tone board - no device found, can't run DFU utility

I have a new Khadas tone board, the simple USB version, just a DAC, Khadas Tone 1 I guess it’s called

I connected it to my Windows 11 PC via USB and in Device Manager I see “Other Devices - Khadas DFU -there are no compatible drivers for this device.”

I ran the Thesycon-Stereo-USB-Audio-Driver-v224 driver package setup. It seemed to complete OK.

When I open the TSUBA control panel it says “No Device Connected”

I followed the instructions on Khadas audio dashboard says no device found - #2 by kenny and ran the [only for some os upgrade xmos]-xmos-tusbaudio-eval-v4.11.0-setup to try to update the firmware, so I ran that old driver setup, and then ran the TSUBAaudioDFU.exe program and it said NO DEVICE CONNECTED

How do I get this BRAND NEW Khadas board to work???

Hi milosz,
From your description, maybe you have not try the new driver.
please try the new driver khadas_tone_driver_v5.30.0_211208

Old tone1 firmware(1.x) match to old driver thesycon-stereo-usb-audio-driver-v224-for-tone1-old-firmware.
New tone1 firmware(2.0 or late) match to new driver.

If that not work, please take some picture for me:

  • Tone1 devie
  • Info recognized by the device manager
  • Info recognized by the dashboard
    Just like this:



That worked IMMEDIATELY!!