Khadas Tea, no longer works with USB

Hey all,

I recently purchased my Khadas Tea used from someone in AVExchange. It has worked great thus far. Unfortunately, recently, I pulled my phone out of my pocket with haste and the Tea disconnected and flew on to the ground. Since then, the Tea doesn’t seem to want to work with my iPhone. However, it does work with BT.

Troubleshooting I have done thus far:

  1. Confirmed the Tea does still power on
  2. Confirmed the Tea does still charge via the USB-C charging port
  3. Confirmed the Tea does work via BT
  4. Confirmed the issue exists on multiple phones (3 iPhones, all three are different models, one with 16.1.1 while the other two are on 16.3.1)
  5. Confirmed the Tea does not work with a brand new MFI certified USB-C to Lightning cable purchased direct from Amazon

So given the factors, I’m at a loss and no longer know what to do. Any help is appreciated.


It seems that there is hardware issue with the KHADAS TEA due to the haste fall.

Please kindly check our service policy here:

For you case, although it’s out of our warranty, please send the device back and we will check if we can repair it. If so, After repairation, we will send it back to you.

Please contact for further process.

Have a nice day ahead.

Hey @Jim129,

So this is interesting. I mentioned in my email, I purchased a new Tea and received it this morning. I confirmed that the new one does not work via USB either.

Is it possible that firmware of some sort needs to be updated?


I think there is no hardware issue for the new Tea. May I know more details about your setup?

Order Number:
Input Device:
Headphone Model:
System of the Input Device:
Serial Number:
Firmware Version:
Headphone Impedance:
Music Player:
Music Format:
Playback while charging: YES/NO

And as for the brand new MFI certified USB-C to Lightning cable you purchased, could you please send me a link on it?

Hey Jim,

I would definitely like to mention that I recently updated my phone along side dropping my previous Tea. I’m wondering if that update affected it. However, I can confirm that I tested the new Tea on my roommates iPhone XS Max phone that has iOS 16.1.1 (20B101) on it and it does not work either. However, it does work via Bluetooth on both phones. Additionally, I attempted to use both the stock USB-C to Lightning and the aftermarket one.

Here is a link to the aftermarket cable:

Order Number: 112-1344072-9862617
Input Device: IPhone 13 Pro Max
Headphone Model: Moondrop Blessing2
System of the Input Device: iOS 16.3.1 (20D67)
Serial Number: XO0X7FL4G4
Firmware Version:
Headphone Impedance: 22Ω@1kHz (±15%)
Music Player: Apple Music
Music Format: ALAC/AAC 16-bit 44.1khz up to 24-bit/192khz
Playback while charging: I don’t know what you are asking here.

I no longer believe that my previous Tea is damaged to the point where it does not work. Especially given the fact that it can charge, it can play via Bluetooth and all the buttons/functions work on the Tea. This is simply an issue with the Tea itself, communicating with the iPhones.


Well noted.

  1. please try to use the included USBC to C cable and test the cable connection with android device or ipad.
  2. If it’s working, I’d recommend you to try our KHADAS USBC to lightning cable: (please send your address to, we will send you a brand new USBC to lightning)

Hey Jim,

Unfortunately, I don’t have access to an Android device that uses the USB-C and the newest iPad I have uses a Lightning connecter.

HOWEVER, just out of curiosity, I tried the new USB-C to Lightning Cable that came with my device with my dropped Tea and it worked just fine. I also tried the new cable with the new Tea and it worked just fine. So seems the issue is the cable!

I’ll gladly send my address to the email if you are still willing to send a new cable out, that would be very much appreciated.


1 Like