Khadas Edge 2 Lights not Turning on


Recently bought the Edge 2, used it for maybe 2 days before installing Armbian earlier today. No issues with getting it flashed, everything running normal within the OS. I turned the computer off to move it to another room, and when I went to plug in power, nothing is happening. No lights, unable to get to Oowow. Before it would flash green for a little, then turn white. Now literally nothing happens when I plug it into any power source. Previous power source that worked fine with it no longer works, tried all different kinds of fast chargers and normal chargers and no luck. Nothing was happening on the software side before this happened. Anyone have any ideas or solutions?

Hello @johndavis29209

Please double check to use the adaptor which works before. And then try to quick press the Func button 3 times in 1 second, can you see the LED flash?

I’ve pressed it three times in quick succession and no luck. I’ve contacted Amazon to get a return. Kinda curious how this could have happen.