Just 2GB RAM visible on VIM3_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530 and lazy fan

I’ve tried the new VIM3_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-2020, but it sees only 2GB of RAM:

khadas@khadas:~$ free
              total        used        free      shared  buff/cache   available
Mem:        1968616      169204     1675080        3656      124332     1769144

It was not the case with focal-4.5 nor bionic-5.5.

Also, the official fan seem to work much less. I mean for the same high load it is mostly off, switching on only for a couple of seconds. Temperatures are around 80C. In the previous images focal-4.5 and bionic-5.5 the fan was on all the time during load, temperatures were better, around 55C.

I know, there is limited possibility of controlling the fan in mainline kernel compared to 4.5, but something is not right in the latest 5.7 kernel.

Hello! Do you have a Basic or Pro version?

Maybe your version of vim3 Basic 2/16

as for the fan, it has several speed modes, as well as automatic mode and its complete shutdown

1 Like

What’s your model of VIM3 ?

VIM3 Basic:

  • 2GB RAM
  • 16GB eMMC.

VIM3 Pro:

  • 4GB RAM
  • 32GB eMMC.

For latest mainline kernel, the FAN works on automatically mode, it’s a little different between previous version.


I’ve got VIM3 Pro, I have used 4GB RAM before. Now I see only 2GB. I’ll check the older Ubuntu image, because meanwhile I also flashed the latest Androind, maybe it is related.

I know, FAN is only in auto mode in the mainline kernel. It does not matter what you put in /boot/env.txt fan_mode=low, mid, high, auto

What I was saying is, that the auto mode of kernel 5.5 as well as auto mode of kernel 4.5 were much more efficient i.e. cooling more than the auto mode of the recent 5.7 kernel.

EDIT: The 2GB memory problem is related to VIM3_Pie_V200624, I tried older VIM3_Ubuntu-server-bionic_Linux-5.5-rc2_arm64_SD-USB_V0.8.2-20200103, but I still see only 2GB. Before the Android upgrade Bionic was showing 4GB. Interestingly, the Android 200624 itself shows 4GB RAM.

The FAN problem is probably something else related to a change between mainline kernels 5.5 and 5.7.

I’m testing with stress --cpu 6
kernel 5.5: FAN on all the time, CPU temperature 61C
kernel 5.7: FAN on 3 seconds, off 10 seconds and so on, CPU temperature 80C

There is also a difference in the LED, if it means anything:
kernel 5.5: LED solid white and red
kernel 5.7: LED white blinking no red

Hello @j.fikar

Thanks for your feedback. We will check this issue.

Can you try to erase the eMMC to compelete boot from the SD card?


If I am right Blinking white LED is indication of kernel 4.9, am I right @numbqq ?

1 Like

Yes, 4.9 kernel use the heartbeat white LED.

1 Like

By chance, I believe there has not been a mash up of 4.9 kernel and 5.7 kernel, if my memory serves me right 5.7 also had, red and white LEDs solid. :face_with_raised_eyebrow:

khadas@khadas:~$ uname -a
Linux khadas 5.7.0 #0.9.1 SMP Tue Jun 2 17:07:41 CST 2020 aarch64 aarch64 aarch64 GNU/Linux

and the white LED is blinking, maybe it is what you call breathing: two short pulses and a little bigger pause

1 Like

I thought Android in eMMC is needed to boot from SD card, is it enough just to erase the eMMC?

I was thinking to flash older Android to eMMC, that was surely working with Bionic 5.5 kernel before.

Ok, good then, my memory has not been working properly for the past few day, my apologies

You can erase eMMC, there should be no problem

1 Like

With VIM3_Pie_V200319 in eMMC I see all 4GB of RAM

khadas@khadas:~$ free
              total        used        free      shared  buff/cache   available
Mem:        3723312      148564     3443128        5848      131620     3529076

FAN: no change, still less efficient with kernel 5.7, it is probably different problem

1 Like

I tried to erase eMMC according to https://docs.khadas.com/vim3/HowtoEraseEMMC.html

Keys Mode: does not work, I got a scrambled logo on the screen, but after restart Android was still in eMMC

Interrupt Mode: does not work, interrupted the USB-C flashing near 15%, but it didn’t boot again. It was somehow still in TST mode. I had to reflash again the older Android till the end. Also switching to Upgrade mode by Keys Mode does not work. I did TST.

CLI Mode: that could work, but I don’t know what is /dev/bootloader, with mainline kernel there are just /dev/mmcblk2, /dev/mmcblk2boot0, /dev/mmcblk2boot1, and /dev/mmcblk2rpmb.

Krescue: the latest Krescue is stuck when the logo is displayed. not sure, if it is related to the latest Android in eMMC

Then I believe there is some problem, better let @numbqq reply to this,

best clean emmc in Krescue and repeat the procedure

Well, I could not boot the latest Krescue. It is stuck in the screen with logo (Khadas logo and down Krescue and version)

hold the power button until loading into Krescue or triple quick pressing the middle button, try differently

You do understand that Guys like Terry put their heart and soul to make sure that specific button combos did those specific things :grin:

There is only one combo that would work in this situation, Which am not sure of, so I guess, Start clicking buttons ! :sweat_smile:

Holding power button works for booting Krescue. Then I erased eMMC (fast), but Ubuntu from SD card does not boot. White led blinks slowly, no HDMI output. It seems Android is really needed to boot Ubuntu from SD card.

Krescue on the other hand boots from SD card with erased eMMC without any button combination.

So I had to flash back the VIM3_Pie_V200319 into the eMMC.

As a conclusion VIM3_Pie_V200319 in eMMC with Ubuntu yields 4GB RAM, while latest VIM3_Pie_V200624 yields only 2GB.

Any thoughts on the fan behaviour? Maybe I’l try older dbt or older kernel 5.4.