Issues with DAC on Raspberry Pi 4


I have bought this DAC:

I connected it to the Raspberry Pi 4 over USB2 and DAC output connected to my headphone amplifier. When I start playing the track using VLC it works fine. Sometimes when I skip to different time or switch to another track there is no output from the DAC. It looks like it’s either looses USB stream or switches to SPDIF. Sometimes it recovers itself when the player switches to new track. Sometimes it recovers when I manually switch to the new track.

I could blame the rest of my system/setup in this issue but the issue DOESN’T EXIST with another DAC based on the Burr-Brown chip. That DAC works as expected. Only when I switch to the Khadas DAC I observe this issue.

Is it a known issue? If so, is there any workaround? Is it possible for example to switch off automatic switching from USB to SPDIF?

Thanks in advance!

BTW, upgrading the firmware to v.2 didn’t help.

I’ve not experienced this issue with my Tone1 (or Tone2 Pro, for that matter). Can you try a different USB cable and different port?

Hi, I’ve tried different cables and ports. It didn’t help.

I’ve also tried another DAC - Topping E30 and found that it has the same issue. Then I tried different player - MPV instead of VLC. With MPV all works fine. So that’s VLC problem. Though one fact still puzzles me that one DAC based on the Burr-Brown PCM2702 doesn’t have the issue.

I searched for VLC issues and found several threads which could probably explain why that happens:

The last post suggested some workarounds which I’ll try to apply.

It looks like VLC slightly changes the audio frequency when it starts the playback. That probably causes the DACs to “loose” the signal. That’s the main theory for now :slight_smile:

Eventually filed the bug: