Issue with NPU acuity-toolkit/bin & doc

we have tested the yolo demos and they are working great. now we want to train our model.

before that I tried to follow these 2 guides to test the conversion of offical yolov3 models.

git clone --recursive GitHub - khadas/aml_npu_sdk
retrieved the files. it complain about submodules missing a certain commit.

fatal: remote error: upload-pack: not our ref 
fatal: Fetched in submodule path 'acuity-toolkit/python', but it did not contain 743a6b32bd480e5c689e8f4aa5be04bb26fcd56d. Direct fetching of that commit failed.

also it seems that the latest version differ from the sdk documentation. the latest master branch is using pegasus and missing convertdarknet. I can generate nn code for mobilenet_tf_nbg_unify but if I try to follow the guide for yolov3. it complain about yolov3_inputmeta.yml is missing and I could not find it in the internet. I am actually planning to test yolor_csp so please give some hints about this _inputmeta.yml file.

I tried to git checkout the only tagged version ( now we have $convert_darknet in demo/ as per the documentation. and no need for _inputmeta.yml. I call
it complain that
…/bin/convertdarknet file is not found.

(base) os@os-GL503VS:~/vim3_tools/aml_npu_sdk/acuity-toolkit/demo$ bash line 34: ../bin/convertdarknet: No such file or directory
  • could you please show how to generate yolov3_inputmeta.yml or yolor_csp_inputmeta.yml as an example & is it compatible with latest sdk we can download (aml_npu_sdk_6.
  • or show me why convertdarknet file is missing from commit


I had fix this error, please try again.

wow, thanks for the quick response. I did git submodule update --init --recursive but the yolov3_inputmeta.yml file is still missing. for my understanding python submodule is used with KSNN and we have built our application with c++.

  • if I should use the latest version could you show how to generate yolor_csp_inputmeta.yml/ yolov3_inputmeta.yml

  • Also, is it compatible with latest SDK available for download v

@osos55 Please post your running command, and please use the latest SDK, the latest SDK should be version 6.4.8.

thank you for resolving this. I still have an issue though which I will post as a new ticket