Is there clear instructions to dual boot for noobs?


#1

Sorry for the noob question. I was just wondering if there is clear instructions on what a person needs to do to get ubuntu loaded on a vim2.

I have a macbook pro not window. The android ubuntu file I just downloaded is .7z 7zip format and wont work.

I read this article and it jumps around a bit and was curious as if there’s an official documentation of sort… Need Instructions for Mac OS

Thanks


#2

My Macbook was broken down, what’s the problems you were meeting?


#3

I’m slowly getting there… I am trying to dual boot andriod and unbutu.

I formatted my sd card to msdos fat32 (32 gig)

unmounted it (/dev/disk2)

Then on http://docs.khadas.com/bootcamp/CreateBurnCardViaCLI/ under uboot commands I get:

dd if=u-boot.bin.sd.bin of=/dev/sdb conv=fsync,notrunc bs=1 count=444
dd: unknown conversion fsync

I assume you need uboot and the VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124.7z file or does that already have everything I need?


#4

Hi, emurph78:
Forgot to tell you that the DualOS ROM only support USB-C Cable upgrade method in Windows, still have issues via uSD card :disappointed_relieved: and will try to resolve in the next build.

In additional, I will write a step by step instructions for MacOS users when my Mackbook back to work.

BTW, it seems that your device is VIM2, but the ROM you downloaded is for VIM1.

Enjoy!


#5

Oh… thanks for the heads up… Maybe a rework of the docs and or short videos would help a lot of folks.

I ran this on my mac:
sudo dd if=/Users/emurph/Desktop/VIM2_Uboot_Nougat_171028/u-boot.bin.sd.bin of=/dev/disk2 bs=1 count=444
444+0 records in
444+0 records out
444 bytes transferred in 1.469388 secs (302 bytes/sec)

Macs don’t use the conv or notrunc… at least from what I read…

Is there a way to dual boot on a Vim2?

Maybe just put ubuntu on the sd card only? I’d like to get it running tonight if possible.

Thanks for your help I really appreciate it a lot.


#6

Yep, you can just keep Android on eMMC and Ubuntu on uSD card, refer Belbes150’s build for uSD card installation:


#7

I tried unsuccessfully to install the dualboot. Does anyone know of any way to install dualboot for macosx or linux?
http://docs.khadas.com/bootcamp/UpgradeViaUSBCable/
This software is for windows xp, who in the world still uses Windows XP ?? Does not have a version for windows 8.1 or 10 x64?


#8

The tools for all Windows, not limited for XP.


#9

I didn’t flash the emmc card I used a 32 gig sd card. Even though I use a mac and know how to put images to bootable disks I used Etcher.


#10

I am not able to install the driver of this software in windows 10 x64, because this is an x32 version.


#11

Hello to everybody. I’ve the 64GB version of vim2. I maked a flash of dualboot system on the emmc , but it steel start on android7. I didn’t see where can i reboot in Ubuntu. tThere is also a critical fact. Now i have 4GB of storage free and the rest till 64GB isn’t seen.
I maked the flash with a windows10 pc. “USB burning tool”.
When the flash finished, i pulled STOP, then i closed program and (at last), unplugged the vim2 from pc
Is the procedure like this?
thanks a lot


#12

I didn’t flash the emmc I used a sd card. If I remember right it boots in andriod first the you have to restart it then it will ask you which OS.

Don’t hold me to it. I’m going off of what I read and seen.


#13

I’ve read that with remote control, ther’s an option to reboot in Ubuntu, but I don’t have it jet.
I’ll try to flash only an Ubuntu OS without android.
I hope don’t have “loosed” others 54GB free’s space.


#14

If you press and hold the power button (the button on the Board) for 1-3 seconds, this is equivalent to pressing the power button on the remote control. In Android, the menu should appear off (with all the extra menu items).


#15

Thankyou. It was all in chineese. Hard work for my eyes to put italian’s language :crazy_face: :grin:


#16

I can’t install the VIM2 Driver on Windows 10, 81, XP to use USB Burn Tools!