Is my Tone1 Bricked [Solved]?

I have both the Tone1 and Tone2 Pro. I updated the firmware on my Tone2 Pro with no problems, but while updating firmware on my Tone1, I accidentally used the Tone2 Pro firmware file instead.

After I realized my mistake, I tried to use the DFU tool to download the proper Tone1 (V2) firmware, but DFU no longer recognizes the DAC. Is this condition permanent?

Before resigning to tossing the Tone1 in the trash, I connected it to my MacBook Pro. Much to my surprise, it showed up as “Khadas Tone Control” and I’m able to play music through it just fine (listening to a DSD64 album using it as I type this).

I guess this is not the end of the world, but I’m sad that I’ve lost the ability to download firmware to my Tone1 due to this simple mistake. Please let me know if there’s anything I can do.

Hello, While I do not have a solution at the moment, I doubt the Tone1 is doomed. Khadas is on Spring break until Feb20. I believe a solution will come at that time.

In the meantime, carefully view this guide and see how it goes. You mention DFU tool, but no mention of new or legacy DFU tool, check guide for relevance.
Good luck.


Hi, you can try to use the the original DFU tools, and update the latest firmware in V2.xx here.


Thanks so much. That actually worked. I’m back!

I do wish the DFU tool made it more difficult to install the wrong firmware, but when installing firmware, it’s always best to check two or three times before clicking “Next”. My fault for not paying better attention, but I’m glad there’s away back (at least in this case).

Now to get back to the task at hand. After updating firmware, I wanted to take measurements of the Tone1 vs. Tone2. I’m curious to see if the Tone2 has the same “ripples” in response as the Tone1 did last time I measured it. Here’s a plot of the Tone1 that compares it’s response with 48 kHz PCM vs DSD64:

I doubt these are audible given the very small magnitude, but this will be fun to explore. Thanks again for the warm welcome and help.