Is my Edge-V Defective?

New User with the Edge-V. Purchased through Amazon here in the US. After unboxing I attached a USB kbd/mouse and HDMI monitor and applied power. The Red/White LEDs come on, and after a second or so the Red LED stays On and the White LED flashes a heart beat pattern. Never any output to the HDMI screen (have tried 2 different screens). Power provided by a 39W USB-C power supply.

Trying to follow the online instructions, I assumed the boot image was missing or bad, so I loaded the USBDriver (DriverInstall.exe) and then AndroidTool.exe. Attempted to put the unit in Upgrade mode using the Long Power press then short Reset, then release the Power button. Red/White LEDs go out, Blue LED goes on. Device is not detected in AndroidTool.exe.

I also tried following the Upgrade instructions for using the USB_Burning_Tool with no device detected.

And finally, I tried the ‘M’ jumper mode. Red LED came on and stays on but the utilities always report no device detected.

Finally have tried this operation on a Win10 Notebook with Docking Station and a Desktop Win10 system.

Ultimately I wish to have Ubuntu running in the EMMc memory.

Any ideas on what I am doing wrong or is this unit defective?

I had similar problems after attempting to use the same method of putting the EDGE-V into Upgrade Mode. That button sequence is almost the same as the sequence that erases the eMMC, which results in no HDMI output. Here’s a link detailing that discussion:

I was more successful with using the TST method: Power on, then 3 presses of the Function button within 2 seconds. Then, AndroidTool detects the SBC as being in Maskrom mode. You should be able to Upgrade the firmware from there.

Also, you need to use the USB-C connector located next to the HDMI for connecting the EDGE-V to your PC. The USB-C beneath the USB2 connector is only for power input. I also needed to utilize that power input, instead of relying on the PC’s USB for powering the EDGE-V.

Please let me know whether this solves your issue, because as you can see from my previous comments, I’m having HDMI sync issues with Khadas’ Ubuntu eMMC images, but not on SD card.:sunglasses:

Thanks, I’ll continue to experiment this evening and weekend.

I was finally able to get the update process to work on a Win7 based computer. Using the process outlined by ‘TheHermit’ I was able to load the most recent version of Ubuntu. After the firmware update process the system booted into the user GUI and I logged in. All seemed to work. I did a shutdown and then restarted the system. Now I have the same issue reported by ‘TheHermit’; “KHADAS” logo screen and brief flash of text and then cycle restarts.

So, something is broken in the most recent version of the Ubuntu build when using the EMMc as the boot storage.

Thank you for the feedback. Glad to hear that my post was helpful.
Although your ‘symptoms’ are slightly different to mine, it indicates that my problem is unlikely to be hardware related. The micro SD card dtb of Ubuntu works fine. The conversation regarding this issue has moved to the following topic:

Perhaps you would like to add your voice and info, too.
I’m going to try the Armbian dtb, as well.
Best of luck.:sunglasses: