Is my build for VIM3 builds fine?


I tried building the Khadas VIM3 Android using the below commands :
. ./build/
lunch yukawa-userdebug

I get this at the end :


wildcard(out/target/product/yukawa/ was changed, regenerating…
15:45:30 ninja failed with: exit status 137

failed to build some targets (02:26 (mm:ss))

how to check if my builds is fine or what issue is there?
Also how can i come to know the total build time.?

Regards, please check this problem

@soong Build AOSPFlash AOSP
The AOSP master branch is Android 12.

This error usually means the build process was killed by the OS in your laptop due to having no RAM left. You can confirm by running dmesg after the error and seeing in kernel logs that your process got killed.

Solutions would be:

Run make with a smaller j value than you're currently using, or Get more RAM, or Add swap space ( disk part that will be used as virtual memory)

ok restarted with -j16.
Will post what happens after build.

again the same error.
can you please tell the steps.

You may need to upgrade your hardware configuration.
Can you post your hardware configuration?

6 vCPU Cores


400 GB SSD

if there is any command which can tell this , you can tell me.
It built fine now , I used -j4 option.
Thanks for all the support !.
Now for flashing can you please point me to the correct link.

I am following this post f yours : How to flash vim3 with android 11 - #23 by Vladimir.v.v
as per this , uboot and flash.img are the only thing.
Is it correct !
Thanks and Regards,

1 Like

Flash AOSP