Install Linux on emmc

I have tried to install linux on the emmc and want to reinstall it. Now i have flashed the arm installer of manjaro to an external drive, but i have problems to boot it, because there is no stock android on the emmc anymore and so i cannot enter dual boot. It still wants to boot into the already installed linux on th emmc. The documentations are also just confusing, as the link of how to activate multi boot just redirects to how to boot intoo upgrade mode. Does anyone know how i can boot into my external drive to install manjaro again fresh to my emmc? Or do I need to flash stock android again to get into multiboot at first?

@kausux88 which version of linux (4.9 or mainline) are you running in the eMMC ?
its most likely 4.9 BSP uboot which doesn’t easily allow linux to boot from external medium,

you have either 2 choices here:

  • you can directly reinstall android on the eMMC and try booting the VIM3 with upgrade mode, this should allow the disk with manjaro to boot.

  • if you do need the eMMC data back up the eMMC using Krescue, then proceed to the step 1 above

if you need to boot Manjaro from external disk, you have to have either android or mainline linux in the eMMC

the choices are up to you, cheers :slightly_smiling_face:

Okay. I’m not sure about the current installed version. Well I guess I will just reinstall android then and proceed from this point. As I dont need to save any data, I can skip a data backup. But Im still wondering about the possibility to change the boot options. Im new to the arm based single board computers, so I was expecting something like a bios or uefi to change it. But as you said, depending on the linux version installed, there may not be any option to boot other medium, so it just directly boot into the os installed on the emmc? Actually it doesnt work to hold down the power button and shortly press the reset button, as described in the documentations, so that may would make sense.

@kausux88 there is no grub/bootselect in uboot (currently),
the upgrade mode might be a light hassle to work with, but you can get used to it after a while, but if you activate upgrade mode once, you don’t need to keep pressing the pwr +rst button everytime you boot from external media, it will only need to be done in the future if you erase the eMMC or such…

A key tip I suggest is to look at the screen when holding the buttons, when releasing the pwr button at the end of the procedure, make sure when you see the khadas logo appear for the second time, you should release at that moment, waiting for any longer or shorter it will not enter upgrade more

best of luck :slight_smile:

At first I tried to install manjaro via krescue, but it did not recognize the version provided by the manjaro download page. In the end I could install uboot on the emmc flash that way and now it recognize the manjaro arm version for khadas vim 3 downloaded from the manjaro webpage, which i flashed on an micro sd card and boot from it just automatically. :+1: