How to use UART in GPIO 14,15,16

I need help to use the GPIO UART (14,15 and16) in VIM3 to control sensors via UART.
Am using ubuntu 18.04 as OS.
How can I check if it’s active or not?


@pergamon You need to clone fenix in our github .
And you can check it dts linux/arch/arm64/boot/dts/amlogic/kvim3l_linux.dts

Thank you for you help.

I just type the following commande and works for me.

sudo fdtput -t s /dtb.img /serial@ffd22000 status okay
sudo fdtput -t s /dtb.img /serial@ffd23000 status okay
sudo fdtput -t s /dtb.img /serial@ffd24000 status okay

The serial port is ttyS3.

@pergamon It was open in default configiure

Hi Frank, pretty new on Khadas. I’m trying to clone fenix but not able to find dts files. Seems folder you mention not exists. Something change from April or there’s something I’ve not understood?


@pergamon ttyS3 is available on default or I have to do something to activate?

@baldodavi Hello, dts not in fenix. After you clone fenix, you should pick vim3 and build , then fenix will clone the linux from khadas github. Then you can find the dts

$ ls fenix/linux/arch/arm64/boot/dts/amlogic/kvim3_linux.dts


Now, we have supports overlay . So you just need to open it in configiure file. Don’t need to rebuild with fenix. You can follow our docs to do it.

Thanks Frank for your reply.
In your opinion modification to env.txt are loaed after a sudo reboot or we need to turn off and turn on khadas. I’m asking because at a point of my work ttyS3 appear magically: I’ve modified overlays in env.txt as reported in docs but after reboot ttyS3 doesn’t come up. Then I’ve unplug khadas after halt to make some test with another platform, when attach Khadas again after some other tests I’ve type ls /dev/tty* and S3 was here.

Thanks, David.

@baldodavi Hello, your modification to this file will take effect permanently and will not be affected by restart. Only restart can reload dtb and extension will