How to use linux kernel I compiled?

What did you use as defconfig for the kernel ?

Can you post your .config file ?

[   10.943018] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.khadas,vim.txt failed with error -2
[   10.954177] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.txt failed with error -2

Another wifi solution,
just use default firmware,
cp brcmfmac43430-sdio.AP6212.txt brcmfmac43455-sdio.khadas,vim.txt
cp brcmfmac43430-sdio.AP6212.txt brcmfmac43455-sdio.txt

1 Like

I removed the files which were already present in the brcm folder from the existing kernel and created this pacman installation file.

Wifi Driver for Linux 5.2.0
Install Wifi Driver for Linux 5.2.0 with the follow command

sudo pacman -U [Filename]

Good idea,

But I still cannot solve gpu problem, it bothers me a lot.

Finally gpu works on my kernel
but I need use XDM to start X server

@Spikerguy @ravelo @Frank
I will create a new image with X(without Desktop Environment) later, you can install desktop environment manually.

I tried:

Works fine with my Wacom tablet
Maybe I should move to a new topic


@_no_proxy . That’s good news. What can I do for you?

Wifi driver seems have some problem.

@_no_proxy. What’s wrong with WiFi driver?

[   10.722256] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[   10.762424] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.khadas,vim.txt failed with error -2
[   10.875747] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[   10.883625] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[   10.907582] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar  1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4
[   11.003705] ------------[ cut here ]------------
[   11.008942] WARNING: CPU: 2 PID: 291 at net/wireless/core.c:868 wiphy_register+0x9a8/0xb00 [cfg80211]

Maybe I need new wifi firmware

I will try this debian wifi firmware.
Still can’t load firmware, I’m trying use old version b43 source code to compile the kernel.

The problem doesen’t seem to be with driver and firmware, maybe I forgot to check PWM support.
it’s solved, I use old core.c core.h in drivers/net/wireless to compile the cfg80211

1 Like

What is the current situation as of now ? Do you have something stable enough to share and for us to test ?

GPU driver fixed problem in new stable kernel(>=5.2.6), I’m waiting for meson HDMI audio driver.

This kernel(5.3.0-rc1) works fine with gpu and wifi.

What do you mean by GPU ? Please advice in detail.

I can’t use old kernel(<5.2.5) to start X, now it has been fixed, and it plays video smoothly.
I guess this file caused that problem.

In which application? any screenshot you have ?can you check the cpu load on youtube videos?

This is a good news. I wanted to built 5.3 but not getting enough time. Will get it ready this weekend.

I tried some local video, and I can’t visit youtube, because it’s not available in my region.
I’ll check cpu usage on some other sites.
The big problem is HDMI audio, I can only use usb sound card.

+ sound/soc/meson/axg-fifo.c                         |    4 +-
+ sound/soc/meson/axg-pdm.c                          |    4 +-
+ sound/soc/meson/axg-spdifin.c                      |    4 +-
+ sound/soc/meson/axg-spdifout.c                     |    4 +-
+ sound/soc/meson/axg-tdm-formatter.c                |    4 +-
+ sound/soc/meson/g12a-tohdmitx.c                    |   38 +-

May it will be added in next kernel.

That is already working dear. Maybe something to do in the kernel you’re using.

These are not for gl and glx which is used for Kvim1
axg and g12a is for Kvim3

@_no_proxy Can you share the config you used to compile the 5.3 kernel ?
Just want to compared it for check I am enabling lima and Panfrost

1 Like