Manjaro Linux - KDE-Plasma & XFCE for VIM1

This is for vim1 please try it

@Spikerguy i did try it yesterday on sd card, keyboard and mouse worked for me, but i need wifi working on it.

1 Like

@Spikerguy OK, I will try it together

I will try to get the wifi firnware for you tonight.

This is the only hint, I get from the dmesg log:

dwc3 c9000000.dwc3: Failed to get clk 'ref': -2

U-Boot does not detect USB storage devices via usb start either. FW version is:

BL2 Built : 15:21:18, Aug 28 2019. gxl g1bf2b53 - luan.yuan@droid15-sz
BL3-1: v1.0(release):53f813e
BL3-1: Built : 15:51:23, May 22 2019
gxl_v1.1.3390-6ac5299 2019-09-26 14:09:24 luan.yuan@droid15-sz
U-Boot 2015.01-gcf11480 (Mar 17 2020 - 16:15:42)

Can you try this?


If it works then i will clean it and add ap6212a file also. As this one doesn’t work on v14 but worked on v12

1 Like

this medieval :japanese_ogre: :sob: need for android in emmc to be able to boot a linux on sdcard is such a terrible experience imposed to the users, according to me.

2 Likes

I agree, hopefully soon we will have mainline uboot so it wont need the Android in emmc but again the bsp uboot and mainline uboot conflict will always be there. In case user is having os with different uboot on emmc and sd card.

Unfortunately it doesn’t work.

Besides that and chromium not working, it looks like a really nice candidate for emmc installation, this is my first impression.

Did you try to install gnome(wayland) on it?

I did try lima on Ubuntu focal(from oibaf ppa), i just set acceleration from none to glamor, glmark2 says that lima is enabled, but i feel i need to add or configure more files, because i can’t get gnome wayland option with display manager, only x11??

About lima, when window compositing is enabled, panel looks blurred on 1920x1080 desktop resolution, more or less all the other stuff look ok, but can i do something about it?

Vim1 has the potential to be a really nice desktop computer, not for professional or gaming use of course, but as a lightweight desktop, very nice board.

Maybe need a different wifi driver. Can you confirm which board do you have? The version is printed on the board itself. V12 or 14?

Do you mean on Manjaro? I have it running on my vim1 so It should work fine on yours too.

No didn’t try that.

I think it is just a lima driver glitch hopefully it should be better once lima matures.

I agree, once lima is in stable production stage then it cab be used as a light weight desktop device.

Hi @Spikerguy, thanks for the quick reply!

If 1.1 doesn’t exist, it’s definitely v1.2.

About Chromium, it doesn’t start, Firefox starts ok, but chromium starts only when setting --use-gl=egl in chromium terminal, this is a lima/chromium bug, i don’t understand how it works for you, but i will check tomorrow?

Can you tell me how did you install this chromium?
The official chromium in our repo is armv8/aarch64 which should work on software acc.

While chromium-docker which I have packaged is chromium armv7 with hardware acceleration and widevine support so this should work fine along with. Netflix and amazon playback.

How to get Netflix to work on Vim1 & Vim2
Please try
sudo pacman -Syyu docker
sudo systemctl enable docker --now

sudo pacman -U https://www.uex.dk/public/manjaro/arm-unstable/community/aarch64/chromium-docker-4.10.1610.6-1-aarch64.pkg.tar.xz

After if is installed you will see Chromium-Armv7 in application launcher.

Also If you want to fix docker permissions then follow this.

  • sudo groupadd docker
  • sudo usermod -aG docker $(whoami)
  • sudo reboot now

Can also watch in 1080p if you want, This will need to be added manually by the user. I have not enable it by default on purpose.
To enable Netflix-1080p Plugin inside Chromium

Navigate to Setting > More Settings > Extension > Enable Developer Mode > Load Unpacked > Browse /usr/lib/chromium-browser/netflix-1080p > Restart Chromium-Armv7

You can check the resolution on Netflix Video Player using Ctrl + Shift + Alt + D and Switch Resolution with Ctrl + Shift + Alt + S
You can set highest bitrate by default in option of netflix-1080p plugin also.

Enjoy.

1 Like

Yeah, thank you, i just remembered you telling me about chromium in docker, i installed this from manjaro repository.

Hope that it’s working now…

@Spikerguy can you please try to find me wifi driver?

@Spikerguy, no luck, followed your instructions, terminal starts but chromium refuses to start.

I now tried reinstalling, tried to run it but without fixing docker permissions, and now it runs, but it is very slow. I have noticed that after upgrading, i don’t have sound anymore.

And one more question, download speed when using ethernet is much faster on Ubuntu, as i remember Vim3 has slower ethernet, i do feel like i am downloading packages over wifi not ethernet, or maybe the downloading server is slow?

Yes thats a possibility.
Can try
sudo pacman-mirrors -G

sudo pacman -Sy

With this it should sync faster.

Can you share a screenshot of htop with chromium-armv7?

Please share screenshot of alsamixer settings.

Thanks.

1 Like

@Spikerguy One screenshot is with htop chromium running, one without, third photo is alsamixer, it doesn’t let me to choose gxhdmi as default sound card, it reverts zo default.IMG_20200516_215253|690x388

This is the third picture, it won’t let me upload three images in a post?