How to update Ubuntu on Khadas?


#1

I tried through software and updates (failed), Synaptic Package Manager (failed). :weary:
Can you guide me on this? :roll_eyes:
Thanks.

PS: I’m far from an expert on linux. :disappointed_relieved:

Aabento


#2

sudo apt-get update
sudo apt-get dist-upgrade


#3

Thank you by your answer but it does not worked.

khadas@Khadas:~$ sudo apt-get update
[sudo] password for khadas:
Hit:1 http://archive.canonical.com/ubuntu zesty InRelease
Ign:2 http://ports.ubuntu.com/ubuntu-ports zesty-security InRelease
Ign:3 http://uk.archive.ubuntu.com/ubuntu zesty InRelease
Ign:4 http://ports.ubuntu.com/ubuntu-ports zesty-security Release
Ign:5 http://uk.archive.ubuntu.com/ubuntu zesty-updates InRelease
Ign:6 http://ports.ubuntu.com/ubuntu-ports zesty-security/multiverse arm64 Packages
Ign:7 http://uk.archive.ubuntu.com/ubuntu zesty Release
/
/
/

Err:6 http://ports.ubuntu.com/ubuntu-ports zesty-security/multiverse arm64 Packages
404 Not Found [IP: 91.189.88.150 80]
Ign:47 http://uk.archive.ubuntu.com/ubuntu zesty-updates/universe Translation-en
Ign:8 http://ports.ubuntu.com/ubuntu-ports zesty-security/multiverse all Packages
Ign:48 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted all Packages
Ign:10 http://ports.ubuntu.com/ubuntu-ports zesty-security/multiverse armhf Packages
Ign:49 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted armhf Packages
Ign:53 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates InRelease
Ign:11 http://ports.ubuntu.com/ubuntu-ports zesty-security/multiverse Translation-en
Ign:50 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted arm64 Packages
Ign:13 http://ports.ubuntu.com/ubuntu-ports zesty-security/universe arm64 Packages
/
/
/

Err:59 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-security Release
404 Not Found [IP: 202.141.176.110 80]
Ign:46 http://uk.archive.ubuntu.com/ubuntu zesty-updates/universe arm64 Packages
Ign:47 http://uk.archive.ubuntu.com/ubuntu zesty-updates/universe Translation-en
Ign:48 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted all Packages
Ign:49 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted armhf Packages
Ign:50 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted arm64 Packages
Ign:51 http://uk.archive.ubuntu.com/ubuntu zesty-updates/restricted Translation-en
Ign:12 http://uk.archive.ubuntu.com/ubuntu zesty/main all Packages
Ign:14 http://uk.archive.ubuntu.com/ubuntu zesty/main armhf Packages
Ign:16 http://uk.archive.ubuntu.com/ubuntu zesty/main arm64 Packages
Ign:18 http://uk.archive.ubuntu.com/ubuntu zesty/main Translation-en
I/
/
/
bled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
khadas@Khadas:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
distro-info-data libgweather-3-6 libgweather-common snapd
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 8727 kB of archives.
After this operation, 1802 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Ign:1 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates/main arm64 distro-info-data all 0.33ubuntu0.4
Ign:2 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates/main arm64 libgweather-common all 3.24.1-0ubuntu0.2
Err:3 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates/main arm64 libgweather-3-6 arm64 3.24.1-0ubuntu0.2
404 Not Found [IP: 218.104.71.170 80]
Err:4 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates/main arm64 snapd arm64 2.29.4.2+17.04
404 Not Found [IP: 218.104.71.170 80]
Err:1 http://mirrors.ustc.edu.cn/ubuntu-ports zesty-updates/main armhf distro-info-data all 0.33ubuntu0.4
/
/
/
/
/
/
E: Failed to fetch http://mirrors.ustc.edu.cn/ubuntu-ports/pool/main/s/snapd/snapd_2.29.4.2+17.04_arm64.deb 404 Not Found [IP: 218.104.71.170 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
khadas@Khadas:~$


#4

make sure your vim can connect to internet and ping
http://uk.archive.ubuntu.com
and at least a few others listed in the log


#5

Something is wrong here: did you manually edit /etc/apt/sources.list and swap xenial to zesty? Because that is the wrong way! A web search will show the correct way in more detail, in short install update-manager-core, check/modify /etc/update-manager/release-upgrades to meet your desires then do-release-upgrade.

I am running 17.10 just fine on my VIM2
> $ lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description: Ubuntu 17.10
> Release: 17.10
> Codename: artful


#6

hi i am not really big on mint and would l would like to just run 17.10 is it a fresh install. did you upgrade to 17.10 or flash it .


#7

I did an upgrade from the Khadas 16.04 server version. (I don’t know of a flashable 17.10 version - suspect it is unlikely for a while as still need to use the 4.9.40 kernel and I am stll using Xorg rather than Wayland.)