How to run my own model with NPU

who can help me please ?

The libs and APP_ABI of VIM3_Pie_V211220.7z are armeabi-v7a, have you switched from arm64-v8a?

it is always armeabi-v7a ,

Look at this Yolov2 model can detect mouse ,

But Yolov3 model detect nothing below

is there anyone can solve this problem ?

Hi all,
I think it is wrong with model convert . would somebody send me yolov5 model or resnet50 model which is converted by aml_npu_sdk please ?

Hi ,

This is log for run yolov3 model

Because we don’t have a ready-made demo, today I will verify whether the NPU of this version VIM3_Pie_V211220.7z is feasible

That’s great ! could you send me Ubuntu Firmware please ? we want to test it !


click to download

Ok,i have downloaded . is there Ai demo could run on Ubuntu please ?

refer to this document

Hi ,
I have installed Ubuntu firmware , but it needs password , what is it ?


The password is the name of our company: khadas, pay attention to lowercase



I copy aml_npu_demo_binaries into the board and enter the directory :
cd {workspace}/aml_npu_demo_binaries/inceptionv3/VIM3
$ ./

it returns:
/bin/sh: 0: Can’t open

What’s wrong with it ?

Then i continue ,
cd {workspace}/aml_npu_demo_binaries/detect_demo_picture
sudo ./INSTALL

it returns:
bash: ./INSTALL: /bin/bash: bad interpreter: No such file or directory

I also try to run
cd {workspace}/aml_npu_demo_binaries/detect_demo
./detect_demo_x11_usb -d /dev/video1 -m 2

it returns as below:

Here are all NPU related documents

Thanks a lot . i read the documents and fellow it ,

cd {workspace}/aml_npu_demo_binaries/inceptionv3/VIM3
I run command above , it return correctly.
When i execute:
./detect_demo_x11_usb -d /dev/video0 -m 2
it can’t open the video and return as below:

Then i run the below command:
./detect_demo_fb_usb -d /dev/video0 -m 2
it shown blurred screen, look here:

I think that maybe someting wrong with the code . do you think about it ?


I am sorry that i always encounter problems .