How to really boot into upgrade mode?

Hi there,
Is there somewhere - anywhere - a documentation with a working method of entering upgrade mode?
So much documentation, so many discussions - but nowhere to find how you can really enter upgrade mode!

Could someone who knows please expain or link to a piece of documentation that actually works?

I tried, all without success:

  • Button pressing thingy
  • Connecting via USB-C on a PC
  • MRegister Mode
  • all the hints and tips that Google spits out

I was able however to successfully flash a new Android image via USB_Burning_Tool - I was hoping with that update, the button press procedure would work (guess what, it didn’t).
Current Android Version:
Model: VIM1
Version: 9
Android security patch level: August 5, 2018
Kernel version: 4.9.113 #5 Thu Aug 22 16:00:30 CST 2019
Build: VIM_Pie_20190823

Online Update on Android throws: “Check Failed!Check Your OTA Service Argent”
Local update does not show any available updates, not even the mentioned zip file.

Is VIM1 just another piece of electronic garbage?

Any help greatly appreciated!

Thanks,
Herwig

Hello and Welcome to the community.

I hope you’re following the steps mentioned in official Khadas documentation

If you follow them step by step you will get to the upgrade mode very easily.

It should work, Maybe try different cable or different USB Port of the host machine, As we have seen these as problem in some cases, which causes it to not enter upgrade mode using both the KeyPress and the M-Key methods.

I dont think OTA works for DIY SBC’s

No Idea about this, But for me it works fine as it should, as I don’t like using android. I keep switching between Ubuntu, Manjaro, LibreElec, CoreElec and Lakka OS. Just waiting for the Lima and mesa to become stable and smooth so Finally I can settle down with Manjaro.

1 Like

Some have mentioned that if the VIM1 is in the DIY case, the USB-C cable may not fully seat. If so, try removing the board from the case and try again.
Also I agree with Spikerguy’s tips on trying a different cable, port and PC. An example of why is here.

1 Like

After lots of trial and error, I finally found the reason why it didn‘t work: The power supply was delivering not enough voltage. With a new power supply it worked flawlessly!
Thank for your help!

1 Like