How to install Windows 10 default driver for KTB?

Can anyone tell me how can I allow Windows to update KTB driver to generic default driver instead of Thesycon

If I let Windows manage the device, this is all I got in device manager.

Screenshot_2 (1)

Can some screenshot to me how Device Manager looks when using generic widnows 10 driver?

Hello, Here is a screenshot of the dev manager. You will notice the XMOS DFU showing as no driver. Also you will notice XMOS USB Audio 2.0 shows as driver installed and working.
Even with XMOS DFU indicating no driver installed, the Tone Board appears to work. It is my understanding that the XMOS DFU is for loading and retrieving firmware from the Tone Board and not required for sound.
This is an excerpt from this PDF from XMOS…
“The DFU loader is a flash device firmware upgrade mechanism.”
It has been a long while since I flashed firmware to the TB, so I don’t recall for certain, however, I would assume TB firmware update package will include a driver for XMOS DFU.
The screenshot of my Win10 DevMan…

I just connected the TB to my Win10 laptop, Windows installed the Window’s driver. If you already have the Theyscon driver installed, uninstall it from the devman, select the delete option if available…
DriverDel

4 Likes

Thanks for your answer.

I deleted Theyscon driver but instead of xCORE USB Audio 2.0 I see ‘Khadas Tone Control’ in Device Manager

I have sound without driver but I can not play 24 bit files because I think proper windows default driver is not installed and I can only see 32bit values in sound control panel. It is buggy. There is not 24bit in the list like I had before with Theyscon driver (screenshot below)

@Gouwa Can you please provide some info for me about this? :smiley: Ty

Hi, did you see my last post?

I updated the TB firmware to 1.04, after doing that the TB shows like yours, "Khadas Tone Control, on Win10 driver. I do not recall seeing 24bit either.
A Khadas Team member may be needed to explain why that changed from Theyscon driver.

1 Like

Firmware bug I think.

Hi Vrbaa,
Sorry for the late response!

Have you adressed your issue?

Hi @Gouwa ,

We both have the same issue. Colleague @RDFTKV got it after upgrading firmware to 1.04. I have it from the beginning because my Tone Board came with firmware 1.04 preinstalled.

@Gouwa Any news about the issue?

1 Like

Oops, I just thougt your issue was figured out, my bad!

@kenny any idea?

Any news???

try ToneBoard on another device! this is necessary in order to understand where the problem is

Yes, I am. Same thing :slight_smile:

My khadas came with firmware 1.04 preinstalled and I can’t see 24bits format either in device manager, but why don’t you just set up 32bits and forget about it?

That is not good solution in any possible way and there are issues. You can not play native 24bit files etc. using WASAPI if you keep using Windows driver and latest firmware.

image @Gouwa