How to enable WOL on Vim2 V1.2

I have a VIM2 V1.2 with Ubuntu server 20.04.3 LTS installed.
I am trying to enable WOL.
Ethtool reports:

Supports Wake-on: d
Wake-on: d

So it is disabled in the system.
If I try to change it with:
sudo ethtool --change eth0 wol g
I get “Operation not supported.”
The documentation indicates to use KBI, but it is not supported by V1.2 boards.
Can you indicate how to enable it.

Hello @achmav

Please check here. VIM2 WOL (Wake-On-Lan) [Khadas Docs]

I know that documentation page. The problem is that I can’t boot into u-boot (pressing Enter or space or Ctrl+C keys at power up), the system gets stuck with the Khadas boot screen (or worse it goes into boot loop).
Maybe it’s me doing the procedure wrong?

I tried accessing the KBI via Krescue, but it says that VIM2 V1.2 is not compatible.

The documentation also indicates to enable WOL with Ubuntu, but since I have the server version, I don’t know how to access that command from the terminal.

Can you give me any suggestions.


Hello @achmav

Checked with image:

You can enable WOL with the command below in the console:

echo 1 | sudo tee /sys/class/wol/enable 

Unfortunately, in my Ubuntu server 20.04.3 LTS the wol directory in /sys/class does not exist and i cannot create it.

I guess you use the 5.x or 6.x mainline kernel, right? If so, WOL is not supported.

Thank you anyway