How to enable I2S for vim4?

We tried making connection using I2S schematic but we are not able to hear audio using I2S module.

Hello @suhas.jarande

Please enable I2S via device tree overlay.

thanks for your quick response

I’m using august build for khadas vim4 and I can’t find the dtb file in source code for the path that you have mentioned and also no where else in the code can you please look at the code and send the correct path.

I’m not sure whether the image you used is released version, but you can try to upgrade the system.

sudo apt update
sudo apt full-upgrade
sudo reboot

If it still not work, we suggest you to install the latest version via OOWOW.

There is some confusion, I am actually looking to build the khadas vim4 android source code from the latest builds, I want to enable the I2S settings the source code itself can you please point out the files for the corrected changes for vim4.