How to disable onboard bluetooth


I would like to ask you for your help. How can I disable onboard bluetooth and use usb bt dongle instead?

The problem is, that onboard bluetooth has very limited range, so I would like to use USB dongle.

Thank you very much

1 Like

Which firmware are you using

I have the same question. I have Khadas VIM2Pro 1.4 with Ubuntu kernel 4.9 on it.

Hi, I think one does not interfere with the other if you want to connect a 2.4G device, as the person described his problem in the first post.

Hi @Renga,

if you want to disable the onboard bluetooth,
Try these commands…

su root
systemctl disable bluetooth.service --force 

If you ever need bluetooth again…
just do,

su root
systemctl start bluetooth.service 
systemctl enable bluetooth.service


As I understand it, they are talking about some kind of device conflict

Yes, we are talking about some kind of device conflict and want to use external device instead of internal. Anyway, i solved my issue, and was able to completely disable internal bluetooth without disabling all Bluetooth stack. It is possible to disable adapter by typing sudo fdtput -t s /dtb.img /bt-dev status disabled


Congratulations. It remains now to figure out how to solve the problem without disconnecting the Bluetooth module, even partially :grin:

Good to hear,

but I don’t understand why you don’t want to use the onboard bluetooth?

If the RF range is your concern, you would be better off with just buying better antennas instead, as you can save the money…

but of course, it is your wish :slightly_smiling_face:

Buddy, the problem is not the antennas, but the firmware

Yes, but I see that they want extended range on their bluetooth, so they are forced to use an external adapter…

My suggestion was aimed towards their hardware problem…

In other words, are you claiming a hardware malfunction and suggesting that they contact a service center?
Or are you saying that vim2’s hardware isn’t good enough?

In arm linux, I have connected up to 3 USB BT adapters (to an RPI) to have a total of 4 hcix BT interfaces availaby for use.
And there is no such thing as a bluetooth device or adapter conflict , Linux and any linux app is fully capable of adressing any adapter among all you can pair and connect any phone/kbd/mouse/headset,etc… to any of the BT adapters you want. In your case @alibababa you will just avoid using hci0 and use hc1 instead

I am saying the existing hardware should be good enough,
but adding some bigger antennas, can boost the range…

Okay, are you sure this will help? and if it doesn’t help? money and time down the drain and thanks Electr1?

Of course, why do you doubt it ?
you can get a pair of antennas for a cheaper price than buying a dongle that has lower range anyways…

but talking about antenna performance is topic that is out of the scope of this discussion…
Let’s try not to deviate here buddy :slightly_smiling_face:

If the topic is still about how to disable, then the answer has been given and we can close the topic.if the real question is about embedded BT perf, so be it, but then please rename the topic subject into something more relevant.

Nobody complained about antennas except you.

You in every topic shy away from the topic buddy, for you this is a normal phenomenon. :man_shrugging:t3::smirk: