How to connect Khadas (Anrdroid) to Raspberry Pi with Ethernet without Router


#1

I want to connect my Khadas (Vim 1 Pro) running Android to my Raspberry Pi with Ethernet without using a router in between. I tried connecting them with one end connected to Khadas and other to Raspberry Pi and even though I put the IP address to both the devices manually, I could not ping one to other.


#2

Hi, Chetu:
May be you can post the commands and more steps/details you did, so we can figure out a solution more easy.

Have fun!


#3

Steps:

  1. Connect one end of ethernet cable to Khadas (Vim 1 Pro) running android
  2. Connect other end of ethernet cable to Raspberry Pi running Ubuntu
  3. Open Termux in Khadas - type in commands - su - ipconfig eth0 192.168.1.2
  4. Open terminal in Raspberry Pi and type in commands - ipconfig eth0 192.168.1.1
  5. Ethernet logo comes up on both devices with exclamation mark
  6. Ping each other

Both the devices shows network unreachable.
My end goal is to send and receive files between these devices using scp or ftp through ethernet port


#4

05%20PM

Hi Chetu,

Have you attempted this using an ethernet crossover cable? That’s required for direct connections.

Have fun!


#5

Hi, Thank you for the reply. I bought and connected the devices with ethernet crossover cable and set the IP address of the Linux running machine to 192.168.1.1 manually, and the android running device to 192.168.1.2 using termux with commands

  1. su
  2. ifconfig eth0 192.168.1.2 up

Then I tried pinging both devices, and on both the devices the error comes as destination host unreachable.


#6

Hi Chetu,

Does this article help? https://helpdeskgeek.com/networking/connect-two-computers-using-a-crossover-cable/

I apologise that I have not had to do ethernet crossovers for over a decade. Hope it still works!


#7

Thank you very much tsangyoujun, It finally worked.