How to boot into u-boot command line?

I setup the serial debugging tool and run kermit with the following output:

Connecting to /dev/ttyUSB0, speed 115200
Escape character: Ctrl-\ (ASCII 28, FS): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.

But I didn’t see any other output below this when I boot the VIM2 by pressing the power button or by WOL.

What’s going wrong? Thanks!

Hello yacca,

Please make sure the connection is right.

I think the connection is correct.

Hi yacca,

Have you connect the HDMI cable to a screen? Does the VIM2 bootup successfully?

Yes, I can start the preloaded Android system successfully. I also enabled the WOL in Android and it works too.

Wrong connected contacts. Use only 3 contacts. Rx Tx GND

I used these 3 pins at the beginning and got the same result as that with VCC pin. :frowning:

Hello yacca,

Does your USB to TTL convertor works well? Have you tried other convertors?


  1. Try swapping the Rx and TX pins. Very often they are written on the Converter “Vice versa”.
  2. Check your TTY settings for programs.
1 Like

It works after I swapped the RX and TX pins. Thank you!