How to boot balbes150 libreelec image?

This is from your log (line 37). Please note - you seem to have tried to run the activation of the multi-boot, but the version of Kszaq. It does NOT support running other images LE. Ie multiboot image Kszaq can ONLY run images that are going to Kszaq. Please note that this does not mean that it is bad multiupload. It’s different variants, each with its own purpose.

bootcmd=if test ${bootfromnand} = 1; then setenv bootfromnand 0; saveenv; else run librefromsd; run librefromusb; fi; run storeboot

I used for sure your image “dd if=LibreELEC-S905.aarch64-17.3_20170614.img of=/dev/sdb bs=4M” . And before that i flashed u-boot and Android from “Vim_Marshmallow_Root_170303.7z” so the u-boot and Android were “clean”.

line 332-333

reading dtb.img
159744 bytes read in 14 ms (10.9 MiB/s)

you have not deleted the dtb.img
del “dtb.img” SD card

1 Like

Yes that was first log which I put online, i’ll check this again asap. But i am sure I deleted (after you wrote it) the dtb.imb file but nothing was on TV. And currently I don’t have serial console access to get new log.

Show the output of printenv from u-boot.

Ok using Android Menu “update&backup” actually works. here is complete log over serial console.
From 1 - 230 line ist just clean u-boot boot and printenv part.

Line 256 show actually reboot mode which is “update” which should be same as doing in “u-boot” the “run update” @Gouwa can you confirm this?
[ 281.279063@0] reboot: Restarting system(init) with command 'update'

From Line 372 shows actually update and activating multiboot mode

@balbes150 if you check old paste log from line 131 you will see this same file. Also this pastelog have printenv which was in that time there.
reading aml_autoscript

Any way I have now @balbes150 LibreELEC booting from microSD. Why it does not work with u-boot “run update” I am not quite sure, but maybe @Gouwa or someone else write this.

Thank you @balbes150 and @harpmaster for your time and instruction.

1 Like

By the way, now you can immediately after burning the image to media, launch images, Kszaq (multiboot to activate more is NOT necessary). In his images has its own version of the script s905_autoscript. This script allows you to run images Kszaq on all systems with universal multiboot. In this script there are extra commands that increase startup time (I wrote about it with a patch to fix it, but he did not use), but the script is working.

This topic was not created to fix the boot issue with @kszaq image, but to use @balbes150 LibreELEC.

Anyway I tried the LibreELEC from @kszaq but it won’t boot (stops on same message as in log I posted in other topic where @kszaq was active. I just power off @balbes150 Libreelec, swaped microSD cards (left @kszaq dtb.img (cp gxl_p212_2g_kvim.dtb sdb1/dtb.img) and power on the device.

Here is boot log

Checked the latest image Kszaq. Everything works. Simply remove the dtb.img. It is not needed. System works fine with dtb data from the internal memory. The remote is recognized and works. I only did not test the installation in eMMC, but I think it will work. :slight_smile:

Thank you for checking @balbes150! Can you provide me a copy of your dtb.img that you have on internal partition so that I can look at device tree I provide and see what is wrong?

Now in eMMC I have a system Armbian (my Ubuntu build). It used this option dtb.

I don’t know, but it seems to me that the regular dtb from firmware needs to work. Anyway, when I had tested my build LE (which based on your GIT) all have working with the standard dtb from firmware.

I now copied on the SD card with your image LE from your dtb Armbian (which is collected from source link). The system is normally started from the SD card and it works (wired LAN, WiFi, BT).

1 Like

indeed after removing @kszaq dtb.img this microSD with his LibreELEC image boots fine.
Here is complete log.
I have as written before Android on eMMC. My goal is to run LibreELEC in eMMC and have ArchLinuxArm for testing on microSD.

Thanks again to @balbes150 and @kszaq

Now you to do everything. Run the LE from external media and execute the installation LE in the internal memory. In the image Kszaq this is done via the SSH connection, and execute the installation command. In my image by selecting in the menu off “Install to eMMC” or similar image Kszaq over SSH. Then you can write the image ArchLinux on the SD card or USB stick. If you connect that media to your VIM will run ArchLinux. When no external media, will run the LE from the internal memory.

Great that would be a setup which I do prefer.

However last night during LibreELEC setup von @kszaq image I found out that there is no WiFi as in your image @balbes150 (wired and wireless are listed in LibreELEC setup in your image), with @kszaq I see only wired network:

@kszaq image: device seems there so it seems just something else is missing:

kvim:~ # ls -l /sys/class/net
total 0
lrwxrwxrwx    1 root     root             0 Jun 12 12:07 eth0 -> ../../devices/c9410000.ethernet/net/eth0
lrwxrwxrwx    1 root     root             0 Jun 12 12:07 lo -> ../../devices/virtual/net/lo
lrwxrwxrwx    1 root     root             0 Jan  1  2015 wlan0 -> ../../devices/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:2/net/wlan0
kvim:~ #

On my way Kszaq shows all the elements of a wired network, available WiFi networks and Bluetooth. Try to add to the media image Kszaq the dtb.img for VIM from the image Armbian\ArchLinux (3.14.29)

Ok seems there is an WiFi timeout?
Immediately after boot if WiFi activated i see all SSIDs. But after some minutes, there will be only Wired Connection shown under LibreELEC -> Connections. Can someone confirm this? I have this when i delete dtb.img and when I use new dtb ‘v2’ from @kszaq from today.

@balbes150 as I don’t have any free microSD card can you just upload somewhere the dtb.img from Arbian\ArchLinuxArm (3.14.29) image?

@kszaq & @balbes150
I am running balbes150 3in1 system and, as proof of concept, I want to try another LE on it
(actually kszaq which I built 64-bit).
I wonder if one can just follow standard LE procedure (put img or tar and dtb in .udpate).
Hereby I assume LE will then do what’s needed.
Or is it safer here, and sufficient, to copy dtb.img kernel.img and SYSTEM to /flash manually?
Thanks both of you for your work on amlogic boxes.
standard procedure cancelled because S912_EMMC.arm and S905.aarch64 not same project.

To work LE from eMMC system 3in1 :

  1. use a universal file “platform_ini” (which may obtain data on the drives and the partitions from the command line).
  2. Other scripts and patches for KODI, for operation reboot into Android and Linux.
  3. Installing to eMMC new version can be performed either by direct copying of the necessary files to the partition “/dev/libreelec”, or through the update procedure from the tar archive.

Pay attention, do not use the standard installation scripts LE in eMMC, it will ruin the system. 3in1 is used in the trigger system using a specially adaptirovano for the scripts that are in /de/multuboot. They described the rules to run in eMMC.


TLDR. Have you tried connecting the USDC for power NOT on PC, TV or computer device? Try connecting USBC to usb power plug commonly used by phone. One of the reason it does not boot is it tries to ‘look’ for something which connected to the USBC.