How di i turn off the light?

Is it possible to turn off the red light when the VIM is powered off? I have it in my room as an open setup and the the red light keeps me up at night, I’ve looked over the setting and anything short of unplugging it every evening doesn’t seem to fix the issue.

What image are you using? Linux or Android?
You could try this. On the VIM3 it should be this, so I expect the VIM4 to be the same.

adb shell “echo 2 > /sys/class/redled/mode”
adb shell “echo none > /sys/class/leds/sys_led/trigger”

Source : Turning off LEDs?

I’m using linux, Been trying to see whether I stick with ubuntu or coreelec.

Hello @NicoD @Anubis


Turn off
Set the LED node parameter to none to turn off the LED:

$ echo none | sudo tee /sys/class/leds/pwmled/trigger

Turn on
Set the LED node parameter to default-on, to make the LED permanently on:

$ echo default-on | sudo tee /sys/class/leds/pwmled/trigger

Set LED heartbeat
Set the LED node parameter to heartbeat, to make the LED flash with a heartbeat blink:

$ echo heartbeat | sudo tee /sys/class/leds/pwmled/trigger

unfortunately this didn’t help, my issue isn’t with the power on led because if it’s on I’m likely awake, my problem is with the red led when the power is off, also the command you listed only seems to work with that session as when I turned off my VIM4 I wend back to the previous setting.

Go to the uboot CLI and run the following commands.

kvim4# kbi led systemoff w off