How can install a new linux distro on VIM2?

I have 2 VIM2 MAX 1.2
Device: VIM2 Amlogic:GXM ver:UNDEF 8 cores 3G ram 58.2 G eMMC.
One is still using the triple OS provided by Balb150 from 2018.
I needed to update the second VIM2 1.2 with some recent distro because the first board with Ubuntu is crashing randomly. It had Nugat on it since bougth.

I can not find nor remember how I installed the triple OS one.
However, checking the web I found out that the recommended way is KRescue.
Unfortunately by the time found it I managed to erase the Android with P+F+R keys and there is nothing on the screen on boot.
The burn-tool from git can not find the device via USB.
There were no problems prepping the sd card with KRescue.
And now, I downloaded and transferred the only 2 available VIM2 EMMC images from the site to the KRescue and tried to write them to the device
open /tmp/mounts/dumps/downloads/vim2-ubuntu-18.04-xfce-linux-4.9-fenix-1.0.11-220429-emmc.img.xz
but KRescue after a few minutes thinking is spitting that they are:
Next, the SCRIPTS the same story with most of the images, not to mention that in the images store there is none for VIM2.
Only Manjaro managed to get to
/dev/mmcblk0p1 and /dev/mmcblk0p2.
When rebooted is getting blank screen.

There is nothing is in the boot partitions or I have to do something more.
It turns out that the image downloaded is meant to be used from SD Card.
I tried to run install to emmc from the KRescue console on the first partition again to no avail.
Why? Because the install script is using lsblk which is not available in KRescue shell, and on the top of that it looks for the /boot on sd card in order to work.
This version of Manjaro HAS NEVER ever worked/been installed in this way at all.
When installed the KRescue to the EMMC, with the SD card out it gets in an endless loop trying to get something over the network.
TFTP from server; our IP
Filename ‘pxelinux.cfg/C0A801E0’
Load address: …

Am I the only one trying to use it?
It looks like nothing is working or maybe I have different expectations.
It seems as nobody has tried before and raised the question on the forums.

Sorry for the long intro but any help will be appreciated.

This image is not for oowow.

Please follow the docs here to install the OS.

  1. Prepare removable disk
  2. start oowow
  3. setup WIFI or Ethernet
  4. install OS via Wizard OOWOW getting started [Khadas Docs]

OOWOW works and Ubuntu and Manjaro images are ok.