Help Needed, VIM1 can't burn the update.img to it

Hello guys,

Khadas VIM1: v1.2 1610
At first, tried Android Pie, downloaded from here, as it didn’t work, tried other images, no sucess.

That’s the first time I try to upgrade my Khadas, bought it from a friend and it came with Android TV 6.0.1 installed, after using it for a quite some time, started to get some connection issues, first with Netflix, then Twitch and many more. So, reading about it, I figured that I should upgrade the VIM to a Normal USER Android, I tried Android Pie, did all the steps as showed here and it never passed 4% Download Boot, it shows me lots of errors as the image I’ll upload. I have the USB-C cable connected and USB-A to USB-A connected for power supply.


I only have tried the USB-C upgrade, haven’t tried the TF Card upgrade, because my computer got no plug for TF Cards. Every time I connect the VIM to the Desktop, it shows up in the USB_Burning_Tool as Connect sucess. I just don’t know how to make it burn sucessfully. Tried different USB ports on the Desktop, different cables but it just don’t work

Hope you guys can help me. Any other information you guys may ask, I’m here to answer, if possible.

Thanks!

Hello, In your screenshot of the USB Burning Tool, the image being flashed is not VIM1_Pie_V190823, it is one of superceleron’s custom VIM1 ROMs. Should also flash OK.
There was an issue, don’t recall if it was on the VIM1, where repeated attempts brought success. You might try leaving the VIM1 connected to the USB Burning Tool, when it fails, hit the stop button, then hit the start button again, if it fails again, repeat a few times to see if it goes through. Otherwise…

It might be a good idea to erase the eMMC first, and then try to flash again. How to erase the eMMC is here.

As for using an SD card, USB card readers can be had for very little. Always a valuable tool to have around.

I appreciate the quick reply, sir.

  • Well, as you said, that’s superceleron’s Custom ROM indeed, I’m just trying anything to se if it works, who knows, right?

  • I’ve already tried repeatedly attempts to flash it, clicking start/stop, no sucess… Tried again just few moments ago, no sucess.

  • I think that I have erased eMMC, but I don’t know what happens when we erase eMMC haha.

  • As for the USB card reader, you’re right. I should have one here, as a matter of fact I have a broken one haha, but with all that situation about the Covid-19, all shops are closed here in my country.

Perhaps I’ll have to wait until I can buy a USB card reader.

Thank you, again.

Hello! it’s time to move on to the second phase, called Krescue, cleaning up eMMC and then updating the system to your vim1.
Step-by-step instruction…

Vladimir, indeed my friend, this could be a very good option!
I’ll try this as soon as I get one USB card reader.
Thanks for the help.

This is not necessary for you, there are many different options, which is why I offer Krescue! good luck to you!

OMG, sorry man, I wasn’t getting what you were trying to say, Let me see if i get it… You’re saying that I have use USB_Burning_Tool to flash Krescue on the VIM?

As I said before, I’m kinda new to this thing of Khadas, and all that stuff… So forgive me for being a little bit ignorant haha.

Thanks for the help.

Everything works fine for you, you just need the right algorithm of actions! Now you do not need to think that something is not working for you, it is confusing and distracting from the right actions :slightly_smiling_face:
Judging by the photo of your first post, you have a usb transfer error.

RDFTKV,
Hello! in fact, this is not entirely true, this is only one way, but there you can act in absolutely many ways
It can work as host, client-server.

1 Like

I thought Krescue had to boot from SD card. I will look at it further. Thanks.

u can write and start krescue from EMMC same as SD, this cool options when u dont have other variants
https://dl.khadas.com/Firmware/Krescue/mega/README.megaimage_online.txt - u can rewrite any os to other os without any additioan stuff , just your vim board!

  • another options krescue stored into SPI flash - and can be started by anytime (not released at this moment - still on test stage )
2 Likes