Help! Can't boot into libreelec

I purchased Amlogic S905X two days ago from, downloaded the Vim_LibreELEC_V161003, and followed the instruction on the web to create a bootable sf card. Plugin the card into the slot, press function button and boot the machine, it didn’t give me a libreelec system, only andorid. I tried the newest Vim_LibreELEC_V170116.7z img, same result. Both version allow me to boot into the android, and pressing the poweroff button shows “reboot into libreelec”, but again, no Libreelec, only android. Pls help me out with this issue!

Hi geohuz,

Can you try balbes150’s build?

Thanks numbqq! before proceeding would you mind to give me the exact download link? I’ve tried one of the images but no luck.

I tried LibreELEC-S912_SD_USB.arm-17.6_20180122-KVIM2, and LibreELEC-S905_SD_USB.aarch64-17.6_20180122-KVIM.img, both of them didn’t work out, the ‘reboot into libreelec’ menu item didn’t show up when pressing the poweroff button. Here is the detail what I’ve done ever since:

  1. Download LibreELEC-S912_SD_USB.arm-17.6_20180122-KVIM2, open the image file, delete dtd.img, rename the file “remote.conf.vim” to “remote.conf”
  2. write the image to external disk
  3. Plug sf card in the device, boot the device, keep pressing the function button, and the device boot into the android.

Is there anything wrong with my operations? Thanks

Hi geohuz,

You need to activate the multi-boot, please refer to this topic:

Hi numbqq, I followed the instruction:

  1. write the img file: LibreELEC-S905_SD_USB.aarch64-17.6_20180122-KVIM.img into the sd,
    sudo dd if=LibreELEC-S905_SD_USB.aarch64-17.6_20180122-KVIM.img of=/dev/disk2 bs=8m

  2. open the sd, make a dir /boot, copy the dtb.img into it. (There is no kvim.dtb, only dtb.img)

  3. Plug into the box, boot the device, in android, I choosed file and reboot

Now the device hangs on Khadas screen. BTW, strangely, I couldn’t boot into upgrade mode, the device hangs on the Khadas screen too.