Hello, my Khadas VIM2 is not included and is not stitched


#1

Hello, my Khadas VIM2 is not included and is not stitched. There is no reaction to pressing buttons and connecting to PC for firmware. Here is the output from kirmit

GXM:BL1:dc8b51:76f1a5;FEAT:ADFC318C:80;POC:3;RCY:0;EMMC:0;READ:0;0.0;CHK:0;
TE: 131409

BL2 Built : 14:59:36, Aug 9 2017.
gxl ge8c6a83 - xiaobo.gu@droid12

set vdd cpu_a to 1120 mv
set vdd cpu_b to 1050 mv
set vddee to 1000 mv
Board ID = 6
CPU clk: 1200MHz
DQS-corr enabled
DDR scramble enabled
DDR3 chl: Rank0+1 @ 912MHz - FAIL
DDR4 chl: Rank0+1 @ 1008MHz - PASS
Rank0: 1024MB(auto)-2T-18
Rank1: 1024MB(auto)-2T-18
DataBus test pass!
AddrBus test pass!
-s
Load fip header from eMMC, src: 0x0000c200, des: 0x01400000, size: 0x00004000
New fip structure!
Load bl30 from eMMC, src: 0x00010200, des: 0x01100000, size: 0x0000d600
Load bl31 from eMMC, src: 0x00020200, des: 0x05100000, size: 0x0002c600
Load bl33 from eMMC, src: 0x00050200, des: 0x01000000, size: 0x00055000
NOTICE: BL3-1: v1.0(release):801e730
NOTICE: BL3-1: Built : 22:09:38, Aug 10 2017
NOTICE: BL31: BL33 decompress pass
mpu_config_enable:ok
[Image: gxl_v1.1.3244-a3237e2 2017-08-16 14:01:18 hong.guo@droid04]
OPS=0x82
wdt: reset registers!
e3 eb ef 46 3 71 e 44 77 7e c4 db [0.446736 Inits done]
secure task start!
high task start!
low task start!
ERROR: Error initializing runtime service opteed_fast

U-Boot 2015.01-g97c7913 (Oct 28 2017 - 14:07:17)

DRAM: 2 GiB
Relocation Offset is: 76ed2000
register usb cfg[0][1] = 0000000077f5aab0
[CANVAS]canvas init
vpu: error: vpu: check dts: FDT_ERR_BADMAGIC, load default parameters
vpu: clk_level = 7
vpu: set clk: 666667000Hz, readback: 666660000Hz(0x300)
vpu: vpu_clk_gate_init_off
vpp: vpp_init
aml_i2c_init_port init regs for 2
MMC: aml_priv->desc_buf = 0x0000000073ed2640
aml_priv->desc_buf = 0x0000000073ed4960
SDIO Port B: 0, SDIO Port C: 1
emmc/sd response timeout, cmd8, status=0x3ff2800
emmc/sd response timeout, cmd55, status=0x3ff2800
init_part() 293: PART_TYPE_AML
[mmc_init] mmc init success
start dts,buffer=0000000073ed71b0,dt_addr=0000000073ed71b0
parts: 3
00: logo 0000000002000000 1
01: ramdisk 0000000002000000 1
02: rootfs ffffffffffffffff 4
init_part() 293: PART_TYPE_AML
eMMC/TSD partition table have been checked OK!
check pattern success
mmc env offset: 0x6c00000
In: serial
Out: serial
Err: serial
reboot_mode=cold_boot
Unknown command ‘cvbs’ - try ‘help’
hpd_state=0
set hdmitx VIC = 16
config HPLL = 2970000
HPLL: 0xc000027b
config HPLL done
j = 4 vid_clk_div = 1
hdmitx: set enc for VIC: 16
HDMITX-DWC addr=0x10004006 rd_data=0x40
Error: HDMITX-DWC exp_data=0xff mask=0x9f
rx version is 1.4 or below div=10
hdmtix: set audio
hdmitx phy setting done
[store]To run cmd[emmc dtb_read 0x1000000 0x40000]
_verify_dtb_checksum()-909: calc a657cd85, store a657cd85
_verify_dtb_checksum()-909: calc a657cd85, store a657cd85
dtb_read()-1031: total valid 2
dtb_read()-1098: do nothing
vpp: vpp_pq_load pq val error !!!
[store]To run cmd[emmc dtb_read 0x1000000 0x40000]
dtb_read_shortcut()-967: short cut in…
Net: __phy_realtek_initdwmac.c9410000amlkey_init() enter!
[EFUSE_MSG]keynum is 4
[BL31]: tee size: 0

[OSD]load fb addr from dts
[OSD]fb_addr for logo: 0x7e000000
[OSD]load fb addr from dts
[OSD]fb_addr for logo: 0x7e000000
[CANVAS]addr=0x7e000000 width=3840, height=2160
saradc - saradc sub-system

Usage:
saradc saradc open - open a SARADC channel
saradc close - close the SARADC
saradc getval - get the value in current channel
saradc test - test the SARADC by channel-7
saradc get_in_range - return 0 if current value in the range of curr ent channel

mac address: 00:00:00:00:00:00
abort power off
boot wol: enable
set_wol: 1
gpio: pin GPIODV_2 (gpi▒


#2

Which version ROM you installed?

BTW, if you want to upgrade a new ROM, check the VIM2 FAQ for the instructions.

Good day!


#3

It was succeeded to set a new firmware, but the device does not turn on. U-boot does not accept any commands, does not even issue the invitation in the command line. It with any version of a firmware.


#4

which version ROM you installed on your VIM2? Not sure you installed a wrong version ROM like VIM1 ROM on VIM2 device.

Good luck!


#5

Hi, I set VIM2_Nougat_V180619.