Headphones Output bug ? Volume problem when using Tone2 Pro as standalone SPDIF converter


I don’t know if someone has already see this thing, but I got the headphones volume at full volume (with impossibility to lower it, even when the led is showing Red color) in this special case :
CD player SPDIF Output -> Coaxial cable -> Tone2 Pro SPDIF Input
The problem is there, with both ports to power the Tone2 Pro (USB cable plugged on I2S port or on USB port)

It’s like the Tone2 Pro, seeing no operating system, set the volume at full on Headphones output like on RCA Output, while only the RCA outputs should be at full.

@Grooved the control knob doesn’t modify the RCA output, it only controls headphone volume :slightly_smiling_face:

You can use the multi-function knob to adjust the gain to high or low. The gain adjustment will work across all outputs, I have not had a chance to check it with SPDIF input, though I assume it will work on any input source.
See video for more info…

@Electr1 @RDFTKV
Hi, I may not have explained it correctly, or you read it too much fast : I get the same thing on the headphones volume than the RCA volume, it’s locked at full in this specific case.

When I use the device on a computer or smarpthone, no problem, I can adjust the volume on the headphones outputs.
But when I used it as standalone via SPDIF Input, the volume is at full on both Headphones and RCA outputs while it should be only at full on RCA output
So it’s certainly a bug in the firmware

@Grooved I have explained in my above post, its not firmware error,
the volume knob does not control the RCA outputs, it only limits the 3.5mm or 4.4mm headphones output

if you need to adjust the RCA output volume, you will need to do so with your own external equipment (headphone amps etc.)

good day

Sorry, but you’re not reading correctly what I said :wink:
In the case I described, the Headphones output is acting like the RCA, it’s not adjustable. (I edited in bold the important part)

I’m not talking about RCA being not adjustable, I know that, I’m talking about the Headphones output being not adjustable.

Ah, my sincere apologies,
I am not sure that is a feature that is there, probably missing rather than a bug, maybe the khadas team can add it in the next release


No worry, I should have wrote in bold the important part.
You’re certainly right, it may not have been set in the firmware

And made a mistake, I should have posted it in the Technical support part. Maybe a mod can transfer this thread

I understand now as well. Apologies for the misunderstanding.
I am curious, does the gain function also unaffect volume under the same situation?
I will try this myself this evening.

Hi, when you use S/PDIF input, the volume of the RCA outputs will always be at 100%. However the 4.4mm and 3.5mm headphone output volumes can be adjusted using the volume knob. The volume knob is analog adjustment, not digital. You may think it is digital.

Please refer to the block diagram below:

thanks for your answer and the schematics.

What you’ve discribed (able to control headphones volume when using SPDIF In) is what I was able to do when my Tone2 Pro was plugged on a computer, and with a SPDIF signal coming.
Meanwhile, if powered as a standalone device (without computer, but with SPDIF Input used), I was not able to control the volume on the headphones output, it was at full volume.

I will try another time, but with a measuring tool, I don’t want to damage the headphones.


Did you lock the volume knob? When you turn the knob, do you see it flash white 3 times? You can triple-push the volume knob to unlock it, before adjusting the volume.

Yes, I thought about this possibility, but lock was not enabled, I saw the red and light blue LED, not white blinking

TEST I just did to find the bug again, after remembering I was about to test it with CD player and my amplifier as standalone SPDIF converter and wanting to compare sound from my amplifier headphones ouput and the one of the Tone2 Pro:
I was using the Tone2 Pro connected to both computer and power supply, and SPDIF from CD player. Input is set on Auto. RCA cable go to the amplifier.

  • launch playing from computer, able to control the volume.
  • then launched the CD player, stop playing on the computer, so the Auto input selection make it goes to SPDIF and the CD is heard. Able to control the volume.
  • once I decided to compare headphones outputs, I disconnect the USB cable between the Tone2 Pro and the computer to leave the power supply only and making it work as standalone converter : still able to control the volume.
  • entered the menu and selected SPDIF manually as Input = bug came back : volume goes from O to full to O to full when you rotate the wheel
    One more thing I just discovered : I have no possibility of changing headphones Gain, the led is all red, whithout a yellow dot indicating if your in Low Gain or in High Gain.
    No, I plugged it back on computer only, and still all red in Gain mode, with volume going random while rotating the wheel, like no sound to maybe 30%, then 0, then 100% then 0.

It’s like selecting SPDIF input manually has bugged my headphones output once again, but now, it stays buggy even after connecting on computer.
No Gain selection possibility, and volume being random when rotating the wheel. Can’t use it with headphones anymore :grimacing:

Just tried to update the firmware with DFU Tools, it was OK and reset it (device is now set @44.1 in the Dashboard while it was @96) but same thing, no Gain adjustement.
So if it’s a bug, it’s not in the XMOS chip but in the other chip (mine is a second batch device, starting with 11A…)

Update : it works again after doing a firmware update (with the same first firmware, not the new one) and use it on a Windows7 computer (I was on Windows 10 computer when the bug appeared, but not sure it’s linked)
I can change the Headphones Gain again and rotating the wheel control the volume correctly, but not sure if I want to try to set the device with SPDIF input only again, hope it did not damage the headphone preamp.
Maybe I will try to use it as standalone SPDIF converter again, but with input on Auto, or using only RCA Outputs, and not the Headphones.

@Eric68 the diagram is great, and we perfectly see the signal path, but where the two Gain level are applied ? Didn’t I got a bug while using SPDIF input because of that ? I don’t know the chip that receive the order to change Gain level ?

Hi Grooved,

Just saw your post. Could it be that your Tone2 Pro was in the “filters adjustment mode”, as witnessed by the “red and light blue LED”?

If your Tone2 Pro is in the “filters adjustment mode”, rotating the volume knob will adjust the “filter selection” and not the “headphone volume”. You will need to double-push, to return to the “volume adjustment mode”.

Of course reflashing the firmware would fix this issue, because it resets the entire Tone2 Pro to the default mode - “volume adjustment”.

Hi @tsangyoujun

unfortunately, no. I’ve checked everything and I was really in a bug. I could browse all of the menu, changing filters, making pause/play, changing tracks, but the one thing I was not able to do was changing the Gain setting, it was all red without the green part at the bottom (Low gain) or at the top (High gain), and volume was making crazy changes from 0 to full without even touching it.

I can try to reproduce it once again if you want, using a cheap headphones that I don’t care to break ?
But maybe the last updates for MCU and XMOS that I made this week have fix it. If that’s the case, it would be a good thing.

Let me know if you want me to try again


1 Like

Sounds like you’ve got a unit with bad MCU firmware. I myself experienced similar issues with a “sticky volume knob” on my pre-production unit - but they cleared up after v1.0 actually, didn’t need v1.2.

If you’re still experiencing these issues, try flashing your XMOS and MCU to the latest firmware versions.


I did both updates. Will try to reproduce it once I have a bit of time available, and let you know.

1 Like

I have not experienced this problem, but I’ll test with the Allo Digione Player this weekend and report back. This setup worked fine under firmware v1.0

Hi, if you want to test, I was using a CD player so it was at 44.1
I will try again this coming days