HDMI output doesn't work

Which system do you use? Android, Ubuntu, OOWOW or others?

Debian bullseye and Ubuntu 22.04 created using fenix 1.5.2. Ubuntu gnome image

Which version of system do you use? Khadas official images, self built images, or others?

Self build image using fenix with no customization what so ever. Also Ubuntu gnome image from oowow

Please describe your issue below:

There is no output on HDMI, tried two different monitors but its the same result. Ubuntu gnome image from oowow shows display on fresh installation but running apt-get update && apt-get dist-upgrade makes it to also fail to display any output on HDMI.

Monitor 1 supports resolution upto 1366x768
Monitor 2 supports resolution upto 2560x1080

Post a console log of your issue below:

When plugging in the monitor, I get the following logs in dmesg:
Monitor 1 - hastebin
Monitor 2 - hastebin

Hello @viraniac

From the logs, it seems that these two resolutions are not supported for current image, have you checked other 1080p screen ?

@numbqq These monitors support more modes like 1280x720 for monitor 1 and 1920x1080 for monitor 2. So I don’t understand why these monitors won’t work for only this device.

Tried third monitor with max resolution of 1920x1080. That doesn’t work as well. Here are the logs - hastebin

Two of these monitors are also from reputed brands i.e. 1 is Samsung and other is LG