HDMI display doesn't work after update

Hi all, I recently updated my VIM3 to the latest kernel and my HDMI display is black on reboot (but I can still SSH into my VIM3). I hooked up a Serial cable to see what the output it and I find these lines:

khadas_support_mode 1920x1200p60hz
bestmode is 1920x1200p60hz, IEEEOUI 0x000c03
lcd: error: outputmode[1920x1200p60hz] is not support
cvbs: outputmode[1920x1200p60hz] is invalid
hdmitx: outputmode[1920x1200p60hz] is invalid
lcd: error: outputmode[1920x1200p60hz] is not support

It seems like the native resolution of my screen is not supported anymore. Does anyone know how to either:
A) change the default resolution to one that is supported by the VIM3
B) have 1920x1200 be supported by the VIM3?

Best regards,

Does the screen works before update?

Can you try to disable the HDMI resolution autodetection? Edit /boot/env.txt to change hdmi_autodetect=yes to hdmi_autodetect=no.

I don’t have screen with resolution 1920x1200, so I’m not sure. Do you have other screen to test.


Yes, the screen worked before the update.
I also followed your advice and set hdmi_autodetect=no and then hdmi=1080p60 and it works now.

Thank you!


@creposukre i guess you have a 1920x1200p60hz monitor ,recently ,i released the vim3 android pie rom,could you help me to test 1920x1200p60hz resolution on vim3 ? please download this rom

1 Like

Hi Jason, sure I have a 1920x1200p60hz monitor and I can try this ROM out

Thank you very much. You can contact me if you have any questions

hi ,@creposukre , have you finished the 1920x1200p60hz resolution test on your monitor , I want to know the result quickly ,So I need you to take a moment to test it for me ,thank you so much !

1 Like