HDMI corruption on NVMe write in Ubuntu & 5.7 kernel

i think its power supply problem!!!
plz show power requirement for your ssd
some ssd nvme - need 10W some only 5-7W + sure your VIM device need something :wink: and sometime its not enough

my recommendation to use ssd from WD blue series which have low power consumption

1 Like

as @hyphop said, it is highly suspected to be a power issue…
but other than that, is your keyboard and mouse stable ?

i have same issues but in my situation - its was full reset when i try read data in maximal speed from NVME - but this problem disappear on another nvme WD blue series

its same problem for VIM and Edge - need good power supply :wink:

Interesting theory… I’m powering the device via a Anker 30W USB-C PD charger and a Nimaso cable that’s rated for 60W. Swapping that for my Dell laptop USB-C PD PSU (rated for 130W), the issue still occurs. If it is power, then I suspect the issue is on the VIM3 not with the PSU.

That said, the drive specification says:
Power Consumption (Active) Avg. read : 2.2W ; Write : 1.7W

…which does lead me to wonder why I see the issue on write, but not read. (I can confirm this with an 8GB file, much larger than RAM, so definitely coming from disk).

Yes, thanks. The USB issue is resolved at least.

1 Like

That is good to hear…

But regarding the SSD, That is kind of a mixed thing as you have to think of it from an electrical engineering standpoint…

for example…
The VIM3 only sips about 4.5-5W of power in Normal usage… but it won’t boot unless you give it 10W bare minimum…

so you have to be able to provide more that it takes…
also don’t forget to take into account that it creates a huge spike in current when starting up or doing tasks…

But you provide more than ample power to the device… perhaps, if you tried to give power via the VIN port, maybe you could ease the power draw ?
as I think there are limitations to the physical device and how much power it is able to draw maximum…

its just digits ! in real life your equipment can get only 5V + and low power quality - and its will be a problem !

WRITE procedure need every time more power than READ !

The drive is rated at 3.3V 0.9A, so shouldn’t draw more than 3W even at peak. Also, the corruption is sustained for the whole write cycle, not just at the start of the activity. I more suspect EMI arising from PCB layout rather than power supply issues, but I’m not enough of an electronics engineer to dig any further.

I did randomly try dropping the PCIe bus speed to 2.5 GT/s to see if that helped, but made no change to HDMI issue though did have the expected effect on throughput.

I spent excessive amounts of time failing to discover any way to change the framebuffer console HDMI resolution to see if that made a difference. The settings in /boot/env.txt seem to be ignored, as were any uboot variables I tried. I got as far as finding /sys/bus/platform/devices/soc/ff900000.vpu/drm/card0/card0-HDMI-A-1/edid (and /modes in same bit of the tree), but haven’t found anywhere in /sys that will let me write a new mode value to change the HDMI PHY.

Powering via the VIN port was vaguely on my todo list anyway to free up the USB-C port, but I don’t have the Molex crimp tool for building a cable. Is there a better alternative than buying the VIN-to-VIN cable, cutting the wires and soldering to a barrel connector?

Anyway, I think I’ve exhausted most of the effort I have for this, given I don’t actually intend to use HDMI in the day-to-day deployment. Thanks for your help, and hopefully this thread might be of some use to the next person to hit similar issues.

1 Like

I don’t know about EMF coming through the boards, as I think the M2X board does have copper layers that should hopefully absorb or deflect the incoming interference…

as for the VIN connector, I am afraid there is no other way to add a connector to it…

I too thank you for testing and cooperating in this problem hunting quest…

good day !

Thanks for the info ! at the moment the question remains open…

That does remind me of one bit of information I don’t think I gave, which may be important if it’s a hardware issue. The NVMe SSD is directly attached to the VIM3 board M.2 socket, not on an M2X board.

I am entirely sure about that part, as no one has reported a problem with that…
As long as the SSD is flushly mounted with the port, it shouldn’t be a problem…
Is it placed at precisely exactly 90° ?, perhaps loose connections are causing foul play here?
I even remember there was a user who created a case, where you could mount the SSD like that…


1 Like

Thanks, I’m using a remix of that case that has a bit more ventilation ( https://www.thingiverse.com/thing:4269209 ). Yes, the SSD is mounted flush, at 90° and held stable.

Also, board temperatures are hovering at around 30°C idle/ 50°C at load, so it’s not a thermal issue. (I have the new style heatsink. No fan on the heatsink itself, but the board is held vertical in a steady airflow from an external fan.)

My mind is still boggled over your problem…
Have you tried other SSDs as well ?

No, I’m afraid that I haven’t got any spare NVMe SSDs to try. They’re still too modern for me to have decommissioned any!

As I’ve said twice now: The board is dead and I’m seeking RMA from Khadas … if I ever get a response.

Maybe you can send a personal message to them,
Katherine and Kenny should help you to do the RMA process…

我也碰到一样的问题。有没有人解决了 ? pcie nvme 和 hdmi 当写大数据操作 nvme时 hdmi 花屏问题

For people reading this thread in attempts to find a solution there was a proposed solution from Khadas team members in another thread posted later and it is to add “pci=pcie_bus_perf” to the kernel cmdline in /boot/Env.txt.

Here is the link to the aforementioned thread:

1 Like