HDMI audio as default output

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas “official” (I think)

Please describe your issue below:

No audio via HDMI output. Not even an option (on default)

Post a console log of your issue below:

The HDMI audio works fine on ALL my other types of computers.  How do I get it on this brandy new VIM4 board, please?  I've searched many places with no success.  ;(
It is not even an option using standard "SETTINGS", only the in-built audio output.  The in-built audio is a no go for my setup as --everything-- else uses the monitor's HDMI audio (with no problems.)
Thanks for any help!

Amazing discovery!
I called up youtube in Firefox and IT plays videos fine WITH the audio coming through just fine in the output using the HDMI cable!!!
So, now that we know the hardware HDMI audio works, how do we turn it on for the sound to be available system-wide? I need all audio to come out via the HDMI monitor but it is still not even listed on the system “settings” program.

No need to setup in Settings, the audio will output to HDMI audio by default.

With a fresh install of Khadas Ubuntu, it works ok on youtube, but nothing else, no other program so far will output any audio. So default is not working. What am I missing?

What program doesn’t output audio?

Looked at another way, youtube is the ONLY program that does play audio through the HDMI.

Hello @skypuppy

How about the preinstalled mpv player? It should works.

The same issue, however in the context of multi-channel audio, has been reported before. Multichannel audio on Ubuntu - #5 by PaulZH

FYI. In CoreElec the HDMI output (even 5.1) can be chosen. In Ubuntu as you indicate not.

/home/david/Pictures/Screenshots/Screenshot from 2023-07-05 11-26-53.png

This is how my “Settings” for audio appears (IF I did it correctly.) Nah, I don’t think that worked.

How do I insert a binary here, please?

Wireplumber turned into a search and config from hell. Sorry.

1 Like