Ftdi_sio.ko missing?


#1

Hi, i am unable to use ftdi serial.
with lsusb i see the attached stick, but no driver is loaded.
in /lib/modules/4.9.40/kernel/drivers there is no usb directory…
any ideas?


#2

FYI:


#3

unfortunately i dont want to reinstall the system :frowning: as it runs my smart home system, with homekit, alexa and openvpn…
so basically i just want to update the kernel… any chance?
edit: but after reading the linked post, it’s about enabling serial uart and not the usb ftdi_sio driver… so it wont help me…


#4

Hello ma666world,

If you use Ubuntu V180531, you can follow the steps to update your kernel to support the FTDI USB Serial Converter.

khadas@Khadas:~$ sudo systemctl stop watchdog  
khadas@Khadas:~$ sudo systemctl disable watchdog
khadas@Khadas:~$ sudo dpkg -r linux-image-amlogic-s912-linux-4.9
khadas@Khadas:~$ wget https://dl.khadas.com/Firmware/test/debs/linux-image-amlogic-4.9_0.4_arm64.deb
khadas@Khadas:~$ sudo dpkg -i linux-image-amlogic-4.9_0.4_arm64.deb
khadas@Khadas:~$ sudo reboot

The USB Serial Converter is built in kernel.

Thanks.


#5

as i installed the device in Feb18 it is the image is probly older… Timestamp form Kernel files is: September 22nd 17


#6

and building the missing module as described in Source for Ubuntu release doesn’t really work… unable to modprobe/insmod the builded ftdi_sio.ko


#7

Hi ma666world,

As ftdi_sio is built in kernel, you don’t need to modprobe/insmod. You just need to replace the Image you build.

Thanks.