[FIXED] Nand-sata-install limite root partition at 4Go


This is my first post and my first experiences under Khadas (1 month).

My configuration:

Linux on sd card:
I used U-Boot: VIM_Uboot_Nougat_171028 / u-boot.bin.sd.bin
No problem.

On the VIMPRO:

Android, after selecting the file aml_autoscript.zip and rebooter, I arrive well under linux.

The problem is that if I run the command nand_sata_install then it creates me a partition / dev / data of 4Go
(this partition becomes after reboot the root partition).

I might skip a step or forget something, but I’ve been blocking this problem for days now,
despite my research on this forum.

Thank you for all information from you.

Armbian uses the installation script in the native Android partitions (root uses the /dev/data partition). Therefore, all partition size limits depend on the current settings in the dtb.

Thank you for your response and your work.

I used the kvim.dtb that I renamed in dtb.img.

Or is there another dtb?

Sincerely Marc.

If you need to change the size of partitions, you need to change their description in the dtb file (change the description in the dts file and collect a new variant with the dtc utility). However, if you use the new option, you must manually move all the data from the old partitions to the new ones.

What I do not understand is that I followed the procedures to be able to install Armbian in EMMC under VIMPRO.

And there, I have to put my hands in the engine, for it to work.

Sincerely Marc.

limit of 4 GB to be the DualOS firmware. This does not apply to Armbian. Flash to eMMC memory the firmware with one Android and then install to eMMC Armbian and you will get more than 12GB for Armbian system.

I do not apply the right method then.

But I do not understand how is the installation “eMMC Armbian” on Android ?

I did not find a link by launching the search with these words.

Sincerely Marc.

See the script /root/install.sh

I tried with another Android version, and before the update “Update & Backup”, the data partition is 11GB.

After running the install.sh and rebooter script, I have a 4GB system partition again.

By cons I found the following link: [How to] Debian Stretch + Linux 4.9 from scratch (w/download, EMMC only)

but I do not know if the method is still operational, and is compatible with Armbian.

Sincerely Marc.

Write down the exact steps you take when you start and install Armbian.

Here are the steps:
sudo dd if =. / Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_server_20171226.img of = / dev / sda bs = 4M
sudo dd if = Uboot / VIM_Uboot_Nougat_171028 / u-boot.bin.sd.bin of = / dev / sda bs = 1 count = 444 && sync
sudo dd if = Uboot / VIM_Uboot_Nougat_171028 / u-boot.bin.sd.bin of = / dev / sda bs = 512 skip = 1 seek = 1 & & sync
I eject the sd card and reinstall it to check that I have two partitions (BOOT, ROOTFS).
cp /BOOT/dtg/kvim.dtb /BOOT/dtg.img
I install the card in a VIM to set up Armbian,
apt-get update apt-get upgrade apt-get install kbd
I stop Armbian and I eject the SD card.
I install the SD card, in the VIMPro which is already under Android.
I go to the settings, “Updates & Backup”
I select alm_autoscript
I am launching the update

and that’s all.

Thank you for looking into my problem.

Sincerely Marc.

These steps are unnecessary.

Do you use two different VIM models ?

Yes to save time, …

You must not?

Ok, that’s fine, now I have a 12GB partition.

Like what, to want too much one loses a lot.

I will test the creation of the image as indicated in the HOW-TO, to make servers under Armbian.

Thank you.

Sincerely Marc.