[FIXED] Midi (on Ubuntu Mate) not working


#1

Hi everyone,
Very happy to ue my Khadas Vim for making music. I’m using an external soundcard (USB) successfully (both input/output). What is not working is the alsa-midi stuff.

I tried to:
sudo modprobe snd_seq

modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='snd_seq'
modprobe: ERROR: could not insert 'snd_seq': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: ../libkmod/libkmod-module.c:977 command_do() Error running install command for snd_seq
modprobe: ERROR: could not insert 'snd_seq': Operation not permitted

Any program that needs to access midi will failed like this:
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory

Do I need to recompile the kernel to loads the modules (alsa midi snd seq stuff)?

Thanks


#2

Yes, The alsa-midi default was disabled.
You need to enable following configs for your midi and recompile the kernel.
Have a try, Thanks.

CONFIG_SOUND_OSS_CORE=y
ONFIG_SOUND_OSS_CORE_PRECLAIM=y
CONFIG_SND_SEQUENCER=y                     
CONFIG_SND_SEQ_DUMMY=y                     
CONFIG_SND_OSSEMUL=y 
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_PCM_OSS=y
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_RAWMIDI_SEQ=y


#3

@terry Can you share a link for a tutorial on how to do this? Or maybe I should consider using the Fenix script (Use Fenix scripts to build your own ubuntu image) to build a complete Ubuntu image?

Or maybe there’s another firmware (.img) that is midi capable?
http://docs.khadas.com/basics/FirmwareResources/


#4

Yes, you need to using the Fenix script to build a complete Ubuntu image.

There is not a firmware for midi capable.
Thanks.


#5

@terry Thanks I was able to build Ubuntu-Mate using the Fenix script (kernel 4.9). But still no snd_seq modules loaded.

What step & what file should I modify to add CONFIG_S(OU)ND to the final .img? I see in the packages/linux-mainline/patches some interesting files that looks like it (adding options to defconfig), but really not sure how to proceed.

Any idea?


#6

packages/linux-mainline/patches is for mainline not linux 4.9.

Can you try this image with alsa midi snd seq enabled? Simply replace /boot/uImage whit this image.

$ cp uImage-4.9 /boot/uImage

Thanks.


#7

It works! I need to keep this file not too far…
Thank you very much for this!