Fix screen resolution / size for a car screen - Edge 2

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas official

Please describe your issue below:

Fixing resolution or screen size for car screen using Khadas edge 2

Hello guys,

I am using Khadas edge 2 to be mirrored in the car OEM screen using Autokit installed in the car it self.

However the icons doesn’t look correct, please see image below:

I know the solution maybe couple of code lines in some file, please advise and very much appreciated…

Please let me know if you need more information…

Thanks a lot …

@Hesham1216 Is your screen an HDMI screen? What is the resolution? Which version of firmware?


Thank you for your response :pray:

No not HDMi
It is mirroring through usb type c cable
I don’t know what is the resolution but if I used mobile phone Samsung galaxy note 9 and working fine
The firmware if you mean on khadas, it is the stock one
Is there new firmware that may fix the problem?

These are some photos of note 9

@Hesham1216 Please reply to this question. If you are using Android 12 version, please try using Android 13 firmware instead.

I will update and let you know brother
Thank you

Hello brother
I downloaded the new version of Android 13
There is nice new features but I still can’t get the resolution right :frowning:

Please check this video and let me know your thoughts:

Video since I can’t upload video


I tried different display option but no luck :frowning:


The resolution settings is off

I think this is because the option turns off when displaying using usb and not HDMi

The screen is stretched

I tried to change the resolution of the application in the car as well but same problem

@Hesham1216 Your problem is easy to solve. I want to know your screen resolution. You can obtain it by executing the wm size command with the adb command.

1 Like

Of course it will be easy for you because you are a genius :smiley:

I executed the command
And this returned:

@Hesham1216 It’s a bit strange. Please execute the following command again and provide the results to see. At the same time, go to the settings application to check the resolution of the DP display?

kedge2:/ # cat /sys/class/mcu/dpmode

When khadas is connected and the screen on display
The command doesn’t show any size

Also the hdmi settings is turned off

This command

kedge2:/ # cat /sys/class/mcu/dpmode

I should execute in khadas terminal? Or car?

How to access khadas terminal?


Please note the khadas edge 2 is being mirrored on car screen through application called autokit (through dongle of apple carplay and android auto)

It is mirrored through usb c cable not HDMI…


It is very important to note:

There are two systems

One is the car system which is android also that is khadas edge 2 connected to (mirrored to)

The other system is khadas edge two also Android

When I executed the command wm size, I executed on the car android command adb not khadas

When khadas is connected the command returns nothing (on the car system) I didn’t try on khadas

If you have time we can try all possibilities together :slight_smile:

I really appreciate your support thank you :pray:

Should I try commands on khadas boards?

Let me go to car and try again I will let you know brother

Appreciate your time very much :pray::bouquet:


Hello brother

Sorry I missed somethings

The resolution now coming from khadas adb (not car)

Excuting the line
kedge2:/ # cat /sys/class/mcu/dpmode

Returned with nothing

And still can’t change hdmi settings it’s disabled

(font may look bigger because I changed settings > khadas settings > display > screen density from 200 to > 240)

Inaccessible or not found


I am in the car for 3 hours

I tried all possible wm adb commands

I changed the density and everything

I think this screen zoom should be accessible from the option it will solve the problem I have a feeling of this…

This photo taken for the car screen density now is 600 :smiley:

Tried to access dpmode but return with nothing