Firmware update failure at 99%


First time poster LOVE Khadas! I just wanted to let you know that the recent ubuntu EMMC xfce build


Will not verify the /uboot partition. The total filename is.


Which was downloaded here.

I used usb burning tool version

The server image: VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20191231

Did write successfully. I am doing this on Windows. I am not sure if this was already known but figured I would let you know.

EDIT:: I just found usb burn tool 2.2.0 and it worked without issue false alarm!

1 Like

Yes, for new image, you must use version 2.2.0.

1 Like

Can someone post, where I can get a 2.2.0 version of usb burning tool?

Thank you!


Thank you! Found a few seconds before I saw this post! :wink: !

1 Like

@Solaris & @numbqq is there any reason, that I do not get any HDMI output?

What image you use? How you supply the power? What’s the resolution of your monitor?

My monitor is FullHD+ 1980x1200, I am using VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20191231.7z extracted of course into .img. One previous image worked with no problem.

I tried to power it through DC adapter and through computer (enough power).

Before I uploaded the Xfce versio I have working server version on it and it seems like it does not upload it entirely or rewrite it.

The image was flashed successful both times I tried.

Have you tried to upgrade the firmware worked before?

I did not, will try this next! THanks!