Fingerprint reader stopped working

Hello everyone, i’m seeking help for what you can read in the title. Some more info, i’ve had my Intel i7 Mind since release, and bought it together with two docks. Fingerprint reader always worked on both since the beginning, but now one of them stopped recognizing my fingers. I even tried setting up new fingers, deleting old ones, disabling and re-enabling the feature, nothing fixed it. The other dock work as intended, and both are on the latest firmware release, 1.04.
The OS i’m using is the stock Windows that came preinstalled in the Mind, before i try sketchy things, what else can i do to try and fix the problem?

Hi @Whippy, did you check if the fingerprint reader is detected properly in device manager ?

You can try reinstalling all the system drivers to see if it is a driver issue:


Hello, thank you for answering, before trying what you suggested i’ll share what i can see in device manager. In the second image it says the device is working correcty, should i try reinstalling the driver anyways? I honestly don’t want to risk messing things up more than they are now…i use this PC to work…


Also, sorry, forgot to remind you, but my second dock still works perfectly, so the issue can’t be the drivers, right?

@Whippy can you share some detailed photographs of the fingerprint sensor on the dock, are all other functionalities of the dock okay ?