Fenix script error

@quatro I check it just now .Firmware itself has some problems, which seem to be caused by the network

so… how can I solve it?

any instructions on how to solve this? Thanks!

@quatro Did you plug in the Internet?

Sorry I don’t understand what you mean…

How can I solve this?

@quatro I’m not sure why. Log shows that ServerIP can’t be found and wait for enternet . It looks like something’s wrong with the ethernet.

How can the boot be interrupted by lack of internet connection?
The device is not showing anything over the HDMI !

@quatro It seems that there is no way to skip this step. From the serial port information, I have been waiting for the network. Your HDMI doesn’t output because you can’t skip this link, so the HDMI driver can’t load.

I’m not understanding… how did it boot the first time I plugged it in if it did not know the credentials for my wifi?

When you start your board, your board will wait for the network port to connect to the network, and it will not enter the next step until it detects that there is a network. There is no problem in our official firmware. I think you have a problem compiling mate desktop. This has nothing to do with your wifi.

I have never connected the Edge to an Ethernet network… and it always booted the system normally… why is now doing that?

@quatro Yes, in the firmware of the official network, we don’t wait for an Ethernet connection. So there’s a problem with your firmware. I don’t know where the problem is. I tried to connect to the network ports, but still reported the same error, that is, the connection to the network ports is ineffective.

Can you generate a ubuntu image for me in that case? I don’t want lxde, I want normal ubuntu…

Also, I tried to burn the official image again but it is not entering upgrade mode… I have used TST and M register mode. TST blinks the blue LED 3 times and then nothing happens, and the rk-burn-tool says it is not in upgrade mode

@quatro I’m not sure if the mate firmware I generated will have the same problem. I can try it out. This desktop has not been maintained for a long time.

isn’t there normal ubuntu (canonical)?

For Edge’s official Ubuntu release, lxde and server.

After burning your firmware, I also encountered this situation.Your firmware DTB doesn’t seem to have any upgrade buttons.By using tweezers, I can reburn firmware.

with the M register you mean?

@quatro Yes.You need to try a few more times. I can burn other firmware after trying many times.