Fan don´t run, I need help


I am new, sorry for my english, I´m spanish. And I new in ubuntu.

I have this firm: VIM3_Ubuntu-gnome-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530

Fan don´t run, in /boot/env.txt is auto, change to high, change to mid, but don´t run.

I put security copy other version and run correctly.

Can you help me, please?

@Rdk206 welcome
In Auto, the fan will turn on only when processer becomes hot…,
If the processer becomes hot, it will automatically turn on…

also, if the env.txt is modified, a system reboot needs to be done to ensure setttings are saved…

you can set it manually in an app too:

  • In Gnome, you can go to the app drawer (represented by this symbol: image )
  • click it, and inside there is a application, called Fan control,
    within the app you can set fan speed manually, it should work

Yes, I know, but when you change fan control for example to high, don´t run is stop same others. I re-install firm and continue.

so is the problem solved after re-install?

No, I was re install and continue with problem.

For mainline FAN control, now switch to standard hwmon driver, so the FAN always works on auto mode, you can’t change the mode via /boot/env.txt.

Ubuntu 20.04.2 LTS aarch64 5.7.0 installed from Krescue:
When i installed os app “FAN control” never installed.
How do i install the app?
I would like the fan to my VIM3 to run at low rpm as standard and dynamically when load rises. How do i do this?

Yeah i have already tried that. Sry wrote the wrong name (FAN setting).
How do i install “FAN setting”?
I am missing this apps gui in programs.
When I from the promt the app starts, i choose and click save but nothing happens.
I am missing: Applications->Settings->FAN Setting

try this one:

I get what your saying btw, the app is something I think the Khadas team made so it may not be availible, at least I cannot find it in a repository so far…