Fail to upgrade with the USB Cable

I have a problem with my Khadas Vim. Tried to do a factory reset and it crashed mid-way through so I now have a bricked device. To HDMI to TV, Power LED Lights up, Box is found in USB Burning Tool but can’t flash with Khadas Vim SCV1-ATV firmware, keeps showing Error [0x00101004]Erase bootloader/Lowper/Identify/Error result. Have also tried the MRegister Mode with no success.
Could someone suggest what to do please.


Try to full erase eMMC before flash also try to add additional power

Have tried Keys Mode of Erasing eMMC both with and without additional power using a USB to USB cable. But still get the same errors on USB Burning Tool.

Any more suggestions?

1 Like

You tried SCV1 but there is SCV2 version on download and try, also if you think that your VIM is broken try another offical VIM image to flash. I think that VIM can also install OS from SDCard but I have not tried it yet, try to find how to flash with SDCard.

Can you kindly try again with the official latest ROM: VIM_Nougat_V171028 and feedback to us?


Missing a driver in Device Manager (GX-CHIP - VID 1B8E / PID C003) which is the Khadas Box. Tried googling for the driver but no luck.

Anyone got a download link for the driver? The USB Burning Tool failed in installing the libusb WorldCup driver, have tried uninstalling and installing the software multiple times.


It’s available on Khadas Docs:

Have fun!

Managed to get the USB Upgrade Tool to install the driver, installed the software then ran the installation file again and it installed the WorldCup driver successfully.

It’s currently in the process of installing the stock Firmware onto the box. Will let you’s know how I get on with it.


1 Like

Got it working 100%, thank you for helping me people.