External CD-ROM / DVD using USB to IDE on Ubuntu

Hi All,

I’m trying to use an old CD-ROM using a USB to IDE converter like this: https://www.amazon.com/gp/product/B07G57971Y/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

It’s working fine (plug & play) in another machine running Ubuntu 20.04, but it’s not working on my VIM3 board using Ubuntu 5.5.

Listing the devices by the command: “lshw -short” I can see the converter “USB to ATA/ATAPI bridge” but not the CD-ROM. The same command in another machine is also listing “RW/DVD GCC-4480B”.

I’m just wondering if there is any missing driver, related to IDE as is too old maybe (??). And if there is something that I can do to solve it somehow, by “modprobe” something, I don’t know (??).

Thanks in Advance!

Hi @hguidi , and welcome to the forum…

Apparently using the 5.5 rc2 kernel release has multiple bugs related to all sorts of things, from USB and SD card problems, to Storage not being recognized…

I highly suggest to update the system to a higher/ latest kernel, I also use a IDE to USB hard disk of 60GB, and it has faced similar problems, my solution as suggested, try my suggestion to see if it works…

good day!

1 Like

Hello and welcome to the forum,

Have you tried to connect it when powered off and power it on with the device connected, if the driver is part of the kernel config then it should show in the lsusb if it is not showing then there is a driver missing.

You will have to find the usb to ide converter chip used in your device and share the model number with that we can search for it driver and recommend you something.
Also as said by @Electr1 try to update to latest kernel that should help.

Good luck.

1 Like

Thank you guys. Following our instructions I replaced the image xfce 5.5 by gnome 5.7 and everything worked well.


Hello! well, this is a standard scheme, you need to check several options different firmware, in order to understand :slightly_smiling_face: