Error when burning images to eMMC

Почему в папке Index of /Firmware/VIM3/AndroidTV или в других папках находятся дистрибутивы с другими операционными системами.
Как их можно залить?
USB Burn tool говорит:
Parse burning image fail

Why are there distributions with other operating systems in the Index of /Firmware/VIM3/AndroidTV folder or in other folders.
How can they be filled?
USB Burn tool says:
Parse burning image fail

@Rinat_Rinat please use images marked with “EMMC” alone for the USB burn tool, and if using the Vim3 use only VIM3 images and for Vim3l use only VIM3L images

good day

1 Like

Why can’t I write images from this folder to emmc?
https://dl.khadas.com/Firmware/VIM3/AndroidTV/

as I said, you can only burn the images of the right format.

How do I install Edge_Debian-minimal-buster_Linux-5.9-rc2_arm64_EMMC_V0.9.6-201209.raw.img?

USB_Burning_Tool

Parse burning image fail

ОК

@Rinat_Rinat you cannot flash image for EDGE on the VIM3

/Firmware/**VIM3/**AndroidTV/
dl.khadas.com/Firmware/**VIM3/**AndroidTV/
Is this confusion in their directories?

Sorry, this directory is confused and we will improve this, but please note if you want to burn image for VIM3, you need to choose the image contain VIM3 mark.

For the raw images, you need to use the krecure to install them, please check:

Why are there distributions with other operating systems in the Index of /Firmware/VIM3/AndroidTV folder or in other folders.
How can they be filled?
USB Burn tool says:

because its just link to same Krescue images collection folder

all images from this collection your can write very easy

just write/start Krescue and make online installation from Krescue wizard -> Index of /Firmware/Krescue/system

good luck

So, I’ve got VIM3L boards. New, sealed. None of them work right out of the box, just flashing K logo on the screen and reboot. I tried writing images downloaded from your web site. All images are marked VIM3L…EMMC… Just one passes the validation stage (Ubuntu 4.9 V 1.0.9). All other give me “Parse burn image fail” error. Even the kresque one. The image that I mention that passes through can be burned to EMMC but does not boot. Any help would be appreciated.

Replying to myself. While the issue with IMG files not loading into the burning software is not resolved, I found a solution to VIM3L not booting issue. I tried to use several different USB-C power supplies and couldn’t make any of my VIM3Ls work. Power supplies with up to 96W output - still no luck. But then I tried some cheap one and it worked. So, basically what I see is none of Apple power supplies can be used. Either VIM designers don’t like Apple or there are differences in protocols for requesting the required current from smart power supplies.

no need download this images, just start krescue from sd card and install all iamges by online

1 Like

You are on the correct path.

I cut the cable and connect to a lab power supply and monitor the current.

So many of the supplies are made for charging batteries and have a very “noisey” output. Another issue is the regulators do not respond quickly. The ARM boards are so fast the power supply cannot keep up with the demand. The power supply must be stiff and noise free.

I doubt it. Raspbery PI 4 works just fine from all the PSU I mentioned. But this is not the point anymore since it works from a simpler (and noisier) power supply. Btw, I am an electronic engineer for the last 40 years. I had a lot of fun reading about “fast ARM boards”.

It will, Pi4 is a horse and buggy compared to the VIM3. At least the VIM3 you can run a SSD from the USB port, try doing that on PI4 (without a powered hub). Most certainly better power management on the VIM 3 regarding that.

Either way all of the devices require a stiff supply with low noise to function properly. Also, what I found from cutting USB cable connectors off is some of them are using the small data wire for power. Now that really changes the power model dramatically. Unless the cable clearly states the max amp capacity I would be cautious in using them.

My RPI 4 work (and boot from) an external SSD connected through USB port. I even have a tutorial on how to do this. But I am just starting with VIMs. Got a lot of them (VIM1, VIM3L). Planning on getting more. PS. Thank you for this discussion. Nice talking to a smart person.

Not really smart, just old, these young people on here are way better at coding than me. Thank you very much for the compliment.

Just an FYI we must be of the same vintage, one of my first classes in college was FORTRAN on a VAX, had to go to the “printer room” to get my hard copy from a line printer. Things sure have changed quickly.

Yes, Fortran and PL-M were my first languages. Started on PDP-11. And the printer room was indeed a loud place.

1 Like